Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#61858 - [plasma-workspace-wallpapers] Smaller resolution images are only symlinks to highest resolution

Attached to Project: Arch Linux
Opened by SLP (s3lph) - Monday, 25 February 2019, 18:55 GMT
Last edited by Antonio Rojas (arojas) - Monday, 25 February 2019, 18:57 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Very Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

Since upstream version 5.15.0, the images provided by plasma-workspace-wallpapers are only shipped in the resolution 2560x1600, all other resolution images are just symlinks to this single image.
This may be desired behaviour for some, but it makes some tools like feh's `--bg-fill` misbehave in the eye of the user if the user expects a file named `1920x1080.jpg` to actually have the resolution 1920x1080 (which, in my opinion, is a reasonable expectation).

Previously (I checked version 5.14.0), the other resolutions were provided as actually resized and cropped images.

Additional info:
* plasma-workspace-wallpapers 5.15.0 and 5.15.1

Steps to reproduce:

1. Install `plasma-workspace-wallpapers`
2. ls -al /usr/share/wallpapers/Autumn/contents/images/
3. Note that every image except `1920x1080.jpg` is a symlink to `1920x1080.jpg`
This task depends upon

Closed by  Antonio Rojas (arojas)
Monday, 25 February 2019, 18:57 GMT
Reason for closing:  Upstream

Loading...