Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#61813 - [i3-gaps] Apply same drawing patch as i3-wm

Attached to Project: Community Packages
Opened by Vuk Mirovic (wooque) - Tuesday, 19 February 2019, 23:33 GMT
Last edited by Brett Cornwall (ainola) - Thursday, 17 October 2019, 01:52 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Morten Linderud (Foxboron)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
i3-wm applies drawing patch that fixes rendering of colored emojis, add the same patch in i3-gaps.

diff for PKGBUILD

27,30c27,28
< source=("${pkgname}-${pkgver}.tar.gz::https://github.com/Airblader/i3/archive/${pkgver}.tar.gz"
< "0001-Use-OVER-operator-for-drawing-text.patch")
< sha256sums=('135c780e4733c3117238fd984ec5716a7feb9b6fea782fbc6b51bb862e6a7ecb'
< '2c1c0d097dc9ef2212fc63f081d1883d39ef7a767234921010d72f41241cf375')
---
> source=("${pkgname}-${pkgver}.tar.gz::https://github.com/Airblader/i3/archive/${pkgver}.tar.gz")
> sha256sums=('135c780e4733c3117238fd984ec5716a7feb9b6fea782fbc6b51bb862e6a7ecb')
35,36d32
<
< patch -Np1 -i ../0001-Use-OVER-operator-for-drawing-text.patch

diff for i3-wm patch

24c24
< @@ -109,7 +109,7 @@ static void draw_text_pango(const char *text, size_t text_len,
---
> @@ -105,7 +105,7 @@ static void draw_text_pango(const char *text, size_t text_len,
30c30
< cairo_set_source_rgba(cr, pango_font_red, pango_font_green, pango_font_blue, pango_font_alpha);
---
> cairo_set_source_rgb(cr, pango_font_red, pango_font_green, pango_font_blue);


Additional info:
* package version(s)
4.16.1-1

This task depends upon

Closed by  Brett Cornwall (ainola)
Thursday, 17 October 2019, 01:52 GMT
Reason for closing:  Works for me
Comment by Brett Cornwall (ainola) - Saturday, 18 May 2019, 21:27 GMT
I'm unable to reproduce; color emoji are rendering on i3status with i3-gaps.

The revert comments [1] seem to suggest that the Cairo end is fixed; upstream is free to apply that patch again now. Since this patch does not make an otherwise-unusable package useable, I'd argue that both i3-wm and i3-gaps should not carry it.

foxboron, do you agree?

[1] https://github.com/i3/i3/pull/2925
Comment by Brett Cornwall (ainola) - Thursday, 17 October 2019, 01:52 GMT
I'm unable to reproduce, and even if I could this is not urgent enough to warrant a patch. I'd poke upstream about reverting their revert. :)

Loading...