Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#61757 - [telegram-desktop] Segmentation fault while connecting to IPv6 dual-stack network

Attached to Project: Community Packages
Opened by Patrick Young (kmahyyg) - Thursday, 14 February 2019, 03:39 GMT
Last edited by Sven-Hendrik Haase (Svenstaro) - Monday, 29 April 2019, 00:30 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Sven-Hendrik Haase (Svenstaro)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:

Unknown reason caused SEGV and then telegram died.(Seems caused by improper handler of network error.)

Additional info:
* package version(s)

community/telegram-desktop From 1.5.4 to 1.5.13(Latest)

```
community/telegram-desktop 1.5.15-1 [installed]
Official Telegram Desktop client
extra/qt5-base 5.12.1-2 (qt qt5) [installed]
A cross-platform application and UI framework
```

* config and/or log files etc.

All configs are default.

Cuz compressed coredumps are still so large(50MiB~), download it from here(All compressed files including a coredump and a log file of gdb. If I found the logging file of telegram itself is useful, it will be attached in the tar file too.):

Version 1.5.4 & Version 1.5.13: https://www.lanzous.com/b591094/

File Access Password: 236t

Steps to reproduce:

- Run telegram-desktop in a dual stack network
- Maybe it is caused by proxy? Trying to set a proxy both via MTPROTO and SOCKS5
- Use it and Wait until it SEGV.
This task depends upon

Closed by  Sven-Hendrik Haase (Svenstaro)
Monday, 29 April 2019, 00:30 GMT
Reason for closing:  Upstream
Additional comments about closing:  Nothing we can do here especially since it appears to be a qt issue. Maybe report a bug against qt or our downstream package in case someone comes along with a patch. I don't think we can patch telegram as it's a qt bug.
Comment by Patrick Young (kmahyyg) - Thursday, 14 February 2019, 07:59 GMT Comment by Sven-Hendrik Haase (Svenstaro) - Sunday, 28 April 2019, 13:16 GMT
Thanks for the report and the research. Do you think there is merit in tracking this downstream since it's a confirmed upstream issue?
Comment by Patrick Young (kmahyyg) - Sunday, 28 April 2019, 15:05 GMT
Just check here: https://github.com/telegramdesktop/tdesktop/issues/5693

I think that may be related to Qt Network Library. Due to other apps written in Qt can sometimes reproduce this bug.

Loading...