Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#61752 - [brltty] should optionally depend on both espeak and espeak-ng

Attached to Project: Arch Linux
Opened by Storm (stormdragon2976) - Wednesday, 13 February 2019, 21:41 GMT
Last edited by Antonio Rojas (arojas) - Thursday, 14 February 2019, 07:22 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Antonio Rojas (arojas)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Brltty currently has a hard dependency on espeak which breaks installation on systems that have espeak-ng installed. Here is the discussion from the Arch General list.


Additional info:

On 2/13/19 3:16 PM, Storm Dragon via arch-general wrote:
> Hi,
>
> I'm having some issues with installing brltty. The problem is, it
> depends on espeak but I'm using the espeak-ng from community and it is
> giving me the unresolvable conflicts problem for that reason.
>
> I don't think that brltty actually needs espeak at all, and it could
> probably be listed as an optional dependancy along with espeak-ng.

$ pkg-list-linked-libraries brltty libespeak
==> checking linked libraries for brltty-5.6-7-x86_64.pkg.tar.xz ...
/usr/lib/brltty/libbrlttyses.so
NEEDED libespeak.so.1


If I understand correctly, this is an optional driver that provides
espeak integration.

Also if I understand correctly, this can be built with another optional
driver /usr/lib/brltty/libbrlttysen.so which would provide espeak-ng
integration. espeak and espeak-ng are not drop-in replacements, but
apparently brltty supports both...

If brltty can simply ignore those modules when they're not loadable it
would make sense to only optdepend on it. By the same token, you might
want to ask for espeak-ng support to be added.

I encourage you to open a bug report asking for this.


* package version(s) all
* config and/or log files etc.


Steps to reproduce:
This task depends upon

Closed by  Antonio Rojas (arojas)
Thursday, 14 February 2019, 07:22 GMT
Reason for closing:  Fixed
Additional comments about closing:  brltty 5.6-8
Comment by Doug Newgard (Scimmia) - Wednesday, 13 February 2019, 23:52 GMT
If it links to libespeak.so.1, it can't use espeak-ng, so this is a non-starter as far as I can see.
Comment by Antonio Rojas (arojas) - Thursday, 14 February 2019, 07:22 GMT
1) espeak-ng support is only in master, not in any released version
2) even if it were, it is simply impossible to compile support for both, since they can't be installed simultaneously in the same chroot

All I can do is make espeak optional.

Loading...