Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#61718 - [kibana] Wrong owner on /etc/kibana/kibana.yml

Attached to Project: Community Packages
Opened by Michael Jacob (mjjacob) - Monday, 11 February 2019, 10:56 GMT
Last edited by Levente Polyak (anthraxx) - Monday, 11 February 2019, 19:59 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Levente Polyak (anthraxx)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

Installation of kibana creates group/user kibana:kibana.
/etc/kibana is owned by kibana:kibana (correct)
/etc/kibana/kibana.yml is owned by root (incorrect)

Kibana fails to start because it cannot read the above file.

Additional info:
* Kibana version 6.6.0-1

After chown'ing the above file to kibana:kibana, it works.

Steps to reproduce:
Install kibana. Start with systemctl start kibana

Feb 11 10:24:12 marvin systemd[1]: Started Kibana - dashboard for Elasticsearch.
Feb 11 10:24:13 marvin node[24170]: FATAL CLI ERROR Error: EACCES: permission denied, open '/etc/kibana/kibana.yml'
Feb 11 10:24:13 marvin node[24170]: at Object.openSync (fs.js:449:3)
Feb 11 10:24:13 marvin node[24170]: at Object.readFileSync (fs.js:349:35)
Feb 11 10:24:13 marvin node[24170]: at readYaml (/usr/share/kibana/src/core/server/config/read_config.js:25:52)
Feb 11 10:24:13 marvin node[24170]: at Object.exports.getConfigFromFiles (/usr/share/kibana/src/core/server/config/read_config.js:50:22)
Feb 11 10:24:13 marvin node[24170]: at RawConfigService.loadConfig (/usr/share/kibana/src/core/server/config/raw_config_service.js:50:52)
Feb 11 10:24:13 marvin node[24170]: at bootstrap (/usr/share/kibana/src/core/server/bootstrap.js:34:22)
Feb 11 10:24:13 marvin node[24170]: at Command.<anonymous> (/usr/share/kibana/src/cli/serve/serve.js:33:33)
Feb 11 10:24:13 marvin node[24170]: at Command.<anonymous> (/usr/share/kibana/src/cli/command.js:116:20)
Feb 11 10:24:13 marvin node[24170]: at Command.listener (/usr/share/kibana/node_modules/commander/index.js:301:8)
Feb 11 10:24:13 marvin node[24170]: at Command.emit (events.js:197:13)
Feb 11 10:24:13 marvin systemd[1]: kibana.service: Main process exited, code=exited, status=1/FAILURE
Feb 11 10:24:13 marvin systemd[1]: kibana.service: Failed with result 'exit-code'.
This task depends upon

Closed by  Levente Polyak (anthraxx)
Monday, 11 February 2019, 19:59 GMT
Reason for closing:  Fixed
Additional comments about closing:  6.6.0-2

Loading...