Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#61712 - [cyrus-sasl] pam.d services missing after updates

Attached to Project: Arch Linux
Opened by Felix Golatofski (TheGoliath) - Sunday, 10 February 2019, 21:42 GMT
Last edited by Jan de Groot (JGC) - Friday, 01 May 2020, 14:39 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:
After the last update, the pam.d services for smtp and imap disappeared. Therefore the authentication via pam doesn't work now. After manually adding them again, it works like a charm.

Additional info:
* package version(s)
2.1.27-1
* config and/or log files etc.
Not needed


Steps to reproduce:
Upgrade to the newest version from the previous one
This task depends upon

Closed by  Jan de Groot (JGC)
Friday, 01 May 2020, 14:39 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Not a bug in cyrus-sasl. Services using saslauthd have to include the pam files.
Comment by Felix Golatofski (TheGoliath) - Sunday, 10 February 2019, 21:45 GMT
Also,
saslauthd only works with cyrus-sasl-gssapi installed.

Cheers
Comment by loqs (loqs) - Sunday, 10 February 2019, 23:06 GMT
Which of the older versions from https://archive.archlinux.org/packages/c/cyrus-sasl/ contains etc/pam.d/smtp or etc/pam.d/imap ?
Without specific pam configurations prior to https://git.archlinux.org/svntogit/packages.git/commit/trunk?h=packages/pambase&id=3552aba772e8bebbe754a4d01f2729e291dd2070
introduced in pambase 20190105.1-1 etc/pam.d/other would have allowed access.
Comment by Jan de Groot (JGC) - Tuesday, 12 February 2019, 10:45 GMT
You need pam.d files for the services that you want to use saslauthd with. This could be imap, pop3, smtp or whatever service that uses saslauthd. I won't include these files in cyrus-sasl, as these don't belong to saslauthd.

I don't see why cyrus-sasl-gssapi is required for saslauthd to work, the gssapi package contains the sasl mechanisms for gssapi, while saslauthd only does PLAIN and LOGIN.

Comment by Eli Schwartz (eschwartz) - Monday, 25 February 2019, 04:09 GMT
  • Field changed: Summary (Cyrus SASL pam.d services missing after updates → [cyrus-sasl] pam.d services missing after updates)
  • Field changed: Status (Unconfirmed → Assigned)
  • Field changed: Architecture (x86_64 → All)
  • Task assigned to Jan de Groot (JGC)
See also FS#61841 for another package that wants to authenticate as the imap domain.

Loading...