Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#61704 - [xlockmore] needs a pam file

Attached to Project: Community Packages
Opened by Alessandro Doro (adoroo) - Sunday, 10 February 2019, 14:36 GMT
Last edited by Sergej Pupykin (sergej) - Thursday, 21 February 2019, 14:54 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Sergej Pupykin (sergej)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 7
Private No

Details

Description:
After the recent changes in pambase, /etc/pam.d/other defaults to deny authentication.
xlockmore depends on pam to authenticate the user and doens't work anymore because it lacks the /etc/pam.d/xlock configuration file.

Creating /etc/pam.d/xlock with this minimal content solves the issue (alert! I'm not a pam expert).
auth required pam_unix.so

Additional info:
* package version(s)
xlockmore 5.56-1
pambase 20190105.1-1
* config and/or log files etc.

Steps to reproduce:
Lock the screen and try to unlock.
The program doesn't unlock the screen ("invalid login").
This task depends upon

Closed by  Sergej Pupykin (sergej)
Thursday, 21 February 2019, 14:54 GMT
Reason for closing:  Fixed
Comment by Alessandro Doro (adoroo) - Sunday, 10 February 2019, 14:45 GMT
Addendum: the source tarball contains the pam config file etc/xlock.pamd

#%PAM-1.0
#auth required /lib/security/pam_stack.so service=system-auth
auth include system-auth
Comment by Klaus Alexander Seistrup (kseistrup) - Sunday, 10 February 2019, 16:38 GMT
See also  FS#61700  - [at] atd: Authentication failure
Comment by Lukas Mosimann (lukasm123) - Wednesday, 13 February 2019, 05:54 GMT
You can manually fix it by adding a file

/etc/pam.d/xlock

with contents

```
auth required pam_unix.so
```

Loading...