Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#61698 - [qtile] Doesn't work with python-cairocffi 1.0.0-1

Attached to Project: Community Packages
Opened by Kwest Ambani (kwestro) - Sunday, 10 February 2019, 01:28 GMT
Last edited by David Runge (dvzrv) - Monday, 11 February 2019, 21:54 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To David Runge (dvzrv)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description: Upgrade breaks Qtile Window Manager - unable to login from display manager or console


Additional info:
* package version(s)
* config and/or log files etc.


Steps to reproduce:

When attempting to login from lightdm / webkit greeter or using "exec qtile" from the console, Qtile fails to launch and brings me back to the ligthdm login screen

The best solution for me at the moment is for me to downgrade python-cairocffi to 0.9.0.1

sudo pacman -U python-cairocffi-0.9.0-1-any.pkg.tar.xz

attached is my .xsession-errors.old file which helped me track down the package that was causing the problem.

also, here are two occurrences that happened in the past that were reported on qtile's issue board:

https://github.com/qtile/qtile/issues/680

https://github.com/qtile/qtile/issues/994

This is my first bug report, so hopefully this helps.



This task depends upon

Closed by  David Runge (dvzrv)
Monday, 11 February 2019, 21:54 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed with 0.13.0-2.
Seems qtile requires a rebuild after each python-{cairocffi,xcffib} upgrade!
Comment by David Runge (dvzrv) - Sunday, 10 February 2019, 11:10 GMT
@kwestro: Thanks! You could also attach your qtile.log (~/.local/share/qtile.log) from that start attempt.

Also thanks for opening the upstream issue [1]. This indeed seems to be a re-occuring issue.

[1] https://github.com/qtile/qtile/issues/1282
Comment by David Runge (dvzrv) - Sunday, 10 February 2019, 11:28 GMT
I just rebuilt qtile against python-cairocffi and this seems to fix the problem (for me).
Please check whether qtile 0.13.0-2 works for you!
Comment by Kwest Ambani (kwestro) - Sunday, 10 February 2019, 16:40 GMT
Thank you, David. That fixed it for me! It works like a charm.

Loading...