Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#61673 - [dmenu] 4.9-1 segfaults immediately on user input

Attached to Project: Community Packages
Opened by fwfull (fluffywaffles) - Friday, 08 February 2019, 01:39 GMT
Last edited by Balló György (City-busz) - Saturday, 30 March 2019, 08:25 GMT
Task Type Bug Report
Category Packages
Status Assigned
Assigned To Levente Polyak (anthraxx)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 6
Private No

Details

dmenu 4.9-1 segfaults once I start typing in the popup. Kernel 4.20.6, running bspwm 0.9.5, st 0.8.1, X server 1.20.3, nothing else.

Downgrade to 4.8 fixes issue.
This task depends upon

Comment by Levente Polyak (anthraxx) - Friday, 08 February 2019, 01:47 GMT
would you maybe actually provide anything useful in this bugreport? like some strace, ltrace, ldd or coredump output?
Comment by fwfull (fluffywaffles) - Friday, 08 February 2019, 01:50 GMT
Apologies for slow uptake on the bug report - never used strace before. You must allow for some innocent ignorance on my part. :)

Ran:

echo 'a\nb\nc' | strace dmenu > strace.out

dmenu popup opened. Pressed enter. Segfault. strace output attached. Indecipherable to one such as me - if there is anything else I can provide will happily comply. Thanks for your patience and for being a package maintainer.

EDIT: sorry captured stdin instead of stderr. Changed '>' to '&>' in test script. Fixing attachment.
Comment by Levente Polyak (anthraxx) - Friday, 08 February 2019, 01:51 GMT
the file is empty, it outputs to stderr not stdout
Comment by fwfull (fluffywaffles) - Friday, 08 February 2019, 01:52 GMT
Sorry, saw that 1s too late to fix it -- my bad. Fixed now.
Comment by Levente Polyak (anthraxx) - Friday, 08 February 2019, 01:59 GMT
you can get coredump information with 'coredumpctl' can you use the 'dump' command on the affected PID to get the stacktrace here?

However, this seems to be some kind of corruption issue in one or the other way, however it works perfectly fine over here.
I don't see this as a packaging issue but as an issue with the upstream software.

Please open a bug ticket at the dmenu bugtracker providing them strace and coredump output via coredumpctl PID dump.
I don't think this is a packaging issue
Comment by fwfull (fluffywaffles) - Friday, 08 February 2019, 02:10 GMT
Thanks for your help - will do!
Comment by Jochen (Alfe) - Wednesday, 13 February 2019, 11:30 GMT
Any updates on this? I have the same issue.
Comment by Brian (blamm9) - Thursday, 14 February 2019, 16:54 GMT
dmenu_run works for me, but I get this issue running i3-dmenu-desktop and j4-dmenu-desktop. Downgrade to 4.8 fixes this.
Comment by Levente Polyak (anthraxx) - Thursday, 14 February 2019, 17:15 GMT
Read the history here: Report upstream where people can fix it.
Comment by Jochen (Alfe) - Friday, 15 February 2019, 07:40 GMT
There seems to be a vivid discussion at the mailinglist of dmenu ( https://lists.suckless.org/dev/1902/33245.html) about this issue. It seems, that this commit ( https://git.suckless.org/dmenu/commit/377bd37e212b1ec4c03a481245603c6560d0be22.html) introduced the broken stuff (from https://lists.suckless.org/dev/1902/33255.html). Seems that upstream is on a good way of fixing; thanks to @fwfull for reporting and investigating there!
Comment by Stefan (Faither) - Saturday, 16 February 2019, 14:47 GMT
Just FYI or if you want to replicate the crash - or make it go away. Here's a work-around:

[code]
#!/bin/bash

unset GTK_IM_MODULE
unset QT_IM_MODULE
unset XMODIFIERS
dmenu_run

[/code]

I've bound this script in my ~/.i3/config
[code]
...
#bindsym $mod+d exec dmenu_run
bindsym $mod+d exec /opt/dmenu_fix
...
[/code]

---- EDIT ----

Alternatively starting fcitx (the IME I use) also mitigated the crashes.
Comment by Jochen (Alfe) - Tuesday, 19 March 2019, 08:22 GMT
Since the issue is solved Upstream with the commit ( https://git.suckless.org/dmenu/commit/f5036b90efd9423d805923a0bc73cd54e30e72ab.html ) mentioned by one of the devs ( https://lists.suckless.org/dev/1902/33278.html ) which was reported as working ( https://lists.suckless.org/dev/1902/33279.html ), can we maybe get a new 4.9 build?
Comment by Jochen (Alfe) - Sunday, 26 May 2019, 15:52 GMT
Since this is now fixed for over two months (and everyone with this issue needs to work around that) can we finally get an updated 4.9-2 with the couple last commits?
Comment by Alex (Sinax) - Tuesday, 11 June 2019, 21:34 GMT
Requesting the same as user above, 4.9-2 would be nice

Loading...