Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#6165 - Kernel 2.6.19 breaks gdb

Attached to Project: Arch Linux
Opened by Eugenia Loli-Queru (Eugenia) - Friday, 05 January 2007, 01:10 GMT
Last edited by arjan timmerman (blaasvis) - Saturday, 06 January 2007, 12:37 GMT
Task Type Bug Report
Category System
Status Closed
Assigned To Tobias Powalowski (tpowa)
Architecture not specified
Severity Medium
Priority Normal
Reported Version 0.7.2 Gimmick
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

The 2.6.19 has a bug that breaks gdb when loaded via Anjuta. When using this kernel version, a developer can not debug his programs via Anjuta. The bug is fixed on 2.6.20, so you might want to backport the patch.
This task depends upon

This task blocks these from closing
 FS#6031 - 0.8 installation ISO showstoppers 
Closed by  Tobias Powalowski (tpowa)
Tuesday, 06 February 2007, 13:49 GMT
Reason for closing:  Fixed
Comment by Tobias Powalowski (tpowa) - Friday, 05 January 2007, 06:33 GMT
could you please post a link to the patch that is needed?
Comment by Eugenia Loli-Queru (Eugenia) - Friday, 05 January 2007, 07:12 GMT
I don't know where the patch is, I only found this when I searched for the bug last night:
https://launchpad.net/ubuntu/+source/linux-source-2.6.20/+bug/74691
Comment by Tobias Powalowski (tpowa) - Saturday, 06 January 2007, 09:21 GMT
i even cannot reproduce the sleep bug here that is mentioned in the bug,
updating gdb now to 6.6 perhaps this fixes your issues
Comment by Eugenia Loli-Queru (Eugenia) - Saturday, 06 January 2007, 09:25 GMT
Create a "hello world" C app with anjuta, build it, then say "Debug" and you should see the error message...
Comment by Tobias Powalowski (tpowa) - Saturday, 06 January 2007, 09:34 GMT
please try the new gdb package here:
http://www.archlinux.org/~tpowa/gdb-6.6-1.pkg.tar.gz
Comment by arjan timmerman (blaasvis) - Saturday, 06 January 2007, 12:38 GMT
it is an kernel bug not an anjuta bug.
Comment by Eugenia Loli-Queru (Eugenia) - Sunday, 07 January 2007, 03:57 GMT
No, the new package did not fix the bug. As Arjan said, it's a kernel bug.
Comment by Tobias Powalowski (tpowa) - Thursday, 11 January 2007, 20:25 GMT
fixed in 19.2?
Comment by Eugenia Loli-Queru (Eugenia) - Friday, 12 January 2007, 05:46 GMT
Nope.
Comment by Tobias Powalowski (tpowa) - Tuesday, 06 February 2007, 13:49 GMT
.20 went to testing, closing this one now

Loading...