FS#61638 - Qt5 update breaks KDE

Attached to Project: Arch Linux
Opened by Atila Neves (atilaneves) - Tuesday, 05 February 2019, 09:38 GMT
Last edited by Antonio Rojas (arojas) - Thursday, 14 February 2019, 09:10 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Antonio Rojas (arojas)
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 7
Private No



KDE wouldn't start on my machine. Since I upgraded the system last night I suspected one of the updates and tried downgrading packages that could affect it. I initially downgraded kwin but that didn't help. So I downgraded all Qt5 updates and the system was usable again. I'm using two monitors with nouveau if that makes a difference.

Additional info:

These are the package updates that broke my system (from /var/log/pacman.log:

[2019-02-04 22:33] [ALPM] upgraded qt5-base (5.12.0-3 -> 5.12.1-1)
[2019-02-04 22:33] [ALPM] upgraded qt5-sensors (5.12.0-1 -> 5.12.1-1)
[2019-02-04 22:33] [ALPM] upgraded qt5-script (5.12.0-1 -> 5.12.1-1)
[2019-02-04 22:33] [ALPM] upgraded qt5-x11extras (5.12.0-1 -> 5.12.1-1)
[2019-02-04 22:33] [ALPM] upgraded qt5-multimedia (5.12.0-1 -> 5.12.1-1)
[2019-02-04 22:33] [ALPM] upgraded qt5-speech (5.12.0-1 -> 5.12.1-1)
[2019-02-04 22:33] [ALPM] upgraded qt5-svg (5.12.0-1 -> 5.12.1-1)
[2019-02-04 22:33] [ALPM] upgraded qt5-declarative (5.12.0-1 -> 5.12.1-1)
[2019-02-04 22:33] [ALPM] upgraded qt5-graphicaleffects (5.12.0-1 -> 5.12.1-1)
[2019-02-04 22:33] [ALPM] upgraded qt5-quickcontrols (5.12.0-1 -> 5.12.1-1)
[2019-02-04 22:33] [ALPM] upgraded qt5-quickcontrols2 (5.12.0-1 -> 5.12.1-1)
[2019-02-04 22:33] [ALPM] upgraded qt5-location (5.12.0-1 -> 5.12.1-1)
[2019-02-04 22:33] [ALPM] upgraded qt5-tools (5.12.0-2 -> 5.12.1-1)
[2019-02-04 22:33] [ALPM] upgraded qt5-webchannel (5.12.0-1 -> 5.12.1-1)
[2019-02-04 22:33] [ALPM] upgraded qt5-webengine (5.12.0-1 -> 5.12.1-1)
[2019-02-04 22:33] [ALPM] upgraded qt5-webkit (5.212.0alpha2-22 -> 5.212.0alpha2-23)
[2019-02-04 22:33] [ALPM] upgraded qt5-xmlpatterns (5.12.0-1 -> 5.12.1-1)

I tried only downgrading qt5-base first but then I couldn't even start sddm so I downgraded all of them.

Steps to reproduce:
Try to start KDE. It hangs.
This task depends upon

Closed by  Antonio Rojas (arojas)
Thursday, 14 February 2019, 09:10 GMT
Reason for closing:  Fixed
Additional comments about closing:  qt5-base 5.10.1-2
Comment by Antonio Rojas (arojas) - Tuesday, 05 February 2019, 10:00 GMT
backtrace? logs? errors?
Comment by Atila Neves (atilaneves) - Tuesday, 05 February 2019, 10:18 GMT
There's no backtrace - KDE just hangs on startup.

I've googled and tried journalctl with both kde and plasmashell but don't seem to have any logs. Where should I be looking?
Comment by Antonio Rojas (arojas) - Tuesday, 05 February 2019, 10:24 GMT
please attach the full journal output of the session
Comment by Atila Neves (atilaneves) - Tuesday, 05 February 2019, 11:14 GMT
What command do I need to run to attach the journal output?
Comment by Bastian Beranek (totsilence) - Tuesday, 05 February 2019, 13:42 GMT
For me KDE Plasma starts and runs OK for a while, but when causing some graphics load (for example: pressing volume up/down in quick succession, which brings forth the volume indicator, which uses blur effect etc...) I experience this:


which I initially thought was a nouveau kernel driver bug (I'm using modesetting as the X11 driver). However, I learned now that the upgrade responsible was either the qt5 5.12.1 upgrade, or the kwin rebuild, since downgrading those fixes the problem for me as well. Could still be a nouveau kernel bug which can't be triggered by the Qt 5.12.0 code?
Comment by Antonio Rojas (arojas) - Tuesday, 05 February 2019, 16:59 GMT
@atilaneves You have an "attach file" button right above the comment box
Comment by Atila Neves (atilaneves) - Tuesday, 05 February 2019, 18:14 GMT
I didn't mean "how do I upload the logs", it's "how do I get the KDE logs". As I mentioned, I tried googling first.

Unless you mean something else by "full journal output"? I hope it's logged to the hard drive as well - once KDE hangs I can't do anything, including switching to a terminal.
Comment by loqs (loqs) - Tuesday, 05 February 2019, 18:16 GMT Comment by patrick (potomac) - Tuesday, 05 February 2019, 23:21 GMT
I can confirm the bug, I use also kde/plasma and my system is broken if I install the last version of qt5 packages (5.12.1-1, 25 packages qt5-***),

the symptoms : plasma boots but it is very very slow, with harddisk led blinking constantly, and an error message "/mnt/wd1000 not accessible" occurs, and I can not move my mouse,
if I open a console (ctrl-alt-f2) then I notice that /mnt/wd1000 is accessible, I tried to type dmesg but I didn't notice error message,

if I downgrade qt5 packages then all is ok, no bugs, so there is a serious bug in qt5 5.12.1-1,
I use radeon HD4650 pci-e graphic card, with the radeon driver, I have an old PC (CPU intel quadcore Q9650, motherboard gigabyte GA-P35-DSL3),
I use one screen (no dual monitor), I use the oxygen theme, it's the first time I notice that plasma is totaly broken after a qt5 upgrade, very strange,

I will try to post journalctl log if I find something interesting
Comment by loqs (loqs) - Tuesday, 05 February 2019, 23:30 GMT
@potomac if you switch to the breeze theme is the issue still present?
Comment by patrick (potomac) - Tuesday, 05 February 2019, 23:51 GMT
@loqs : if I switch to breeze then all is ok, no bug,

so there is an incompatibility between the oxygen theme package (and maybe other themes) and the qt5 packages in version 5.12.1-1
Comment by Bastian Beranek (totsilence) - Tuesday, 05 February 2019, 23:54 GMT
My issues are present even though I'm using breeze. Also the symptoms are very different for all three people who reported problems. So maybe we should have separate tickets, not sure what you prefer.
Comment by patrick (potomac) - Tuesday, 05 February 2019, 23:58 GMT
It would be interesting if Atila Neves can tell us which theme he uses, default theme (breeze) or a custom theme like oxygen ?
Comment by huot jean francois (jfh) - Wednesday, 06 February 2019, 07:54 GMT
Hello, I confirm the bug, the qt5-5.12.1-1 update breaks my KDE/PLASMA session(breeze theme). The log shows errors regarding the new nvidia driver. I switch to Nvidia-340xx and all is OK, no bug.
Comment by Atila Neves (atilaneves) - Wednesday, 06 February 2019, 09:12 GMT
I'm using the Breeze theme. As mentioned earlier, I'm using the nouveau driver. Yesterday I remembered that I froze nouveau a while back because it broke my dual monitor setup thinking that might be it, but now that I've seen others experience the same bug I don't think so.
Comment by Atila Neves (atilaneves) - Wednesday, 06 February 2019, 09:19 GMT
I managed to find the logs for one of the failed starts. It has a stack trace in it. I've attached the file.
Comment by patrick (potomac) - Wednesday, 06 February 2019, 09:21 GMT
it seems that I have to open a new archlinux bug report (for oxygen archlinux package), as Atila Neves doesn't have exactly the same bug (I suggest to edit the title in order to avoid missunderstanding),

I have created a report in kde bugzilla for oxygen component :
Comment by Pavel (bartender) - Wednesday, 06 February 2019, 16:58 GMT
I confirm: SDDM was receiving SIGTERM right after start until I downgraded Qt packages from 5.12.1 to 5.12.0.
Comment by patrick (potomac) - Wednesday, 06 February 2019, 20:03 GMT
@Pavel : Do you have the bug if you start kde/plasma with xinit/startx instead of using sddm ?

Comment by Pavel (bartender) - Thursday, 07 February 2019, 08:55 GMT
Yes, that way various Plasma apps crash on start (crash dialogs appear).
My video driver is nouveau.
Comment by Shay G (Tharbad) - Thursday, 07 February 2019, 17:35 GMT
Since that update I can't open any apps from the Application Menu (They just close without any error).
I can open them in cmd with no errors. Nothing in logs.
KDE on nvidia proprietary driver (ck version).
Downgrading works.
Comment by patrick (potomac) - Thursday, 07 February 2019, 19:14 GMT
it would be interesting to see if Qt5 5.12.1 triggers crashs also in other desktop management like gnome, xfce, lxqt, when opening a Qt5 application and when the graphic driver is nvidia,

identify the faulty package among the 25 packages of Qt5 can help Qt5 developers to find a fix, the release notes of Qt5 5.12.1 :
Comment by hamelg (hamelg) - Thursday, 07 February 2019, 19:47 GMT
Here, when opening my kde session plasmashell eats all the memory and is OOMKilled.
see here : https://bbs.archlinux.org/viewtopic.php?pid=1830703
Comment by patrick (potomac) - Thursday, 07 February 2019, 19:57 GMT
thanks hamelg for the link, I discover that other archlinux users notice also a problem when using oxygen theme, and they think it can be caused by an excessive memory consumption from a component of Qt5 5.12.1 (memory leak ?),

it can explain the extreme slowness (which I interpreted as a hang/frozen desktop), all this need more investigation, but it's not easy as there is no useful logs when the crash/hang occurs
Comment by patrick (potomac) - Friday, 08 February 2019, 11:29 GMT
the bugreport in qt5 bugtracker :

Comment by Pavel (bartender) - Friday, 08 February 2019, 13:47 GMT
My theme isn't Oxygen, I use Breeze everywhere.
Comment by Antonio Rojas (arojas) - Friday, 08 February 2019, 15:43 GMT
Please test 5.12.1-2
Comment by Bastian Beranek (totsilence) - Friday, 08 February 2019, 18:26 GMT
Thanks @arojas, works for me (but that's not surprising since I was the one who did the bisect in the qt bug report).
Comment by patrick (potomac) - Friday, 08 February 2019, 20:16 GMT
I tested Qt5 5.12.1-2, it doesn't solve my bug, when using oxygen theme I still have crash (memory leak, all my 8 Gb ram are used)
Comment by Shay G (Tharbad) - Friday, 08 February 2019, 21:19 GMT
I asked other people in the local linux group. This appears to be a nvidia + qt bug.

I'm using oxygen. Also I had to downgrade the following packages before i could open system settings to check what theme I'm using:
qt5-base qt5-location qt5-xmlpatterns qt5-webchannel qt5-webkit qt5-webengine qt5-tools qt5-quickcontrols2 qt5-quickcontrols qt5-graphicaleffects qt5-svg qt5-multimedia qt5-speech qt5-x11extras qt5-script qt5-sensors qt5-serialport qt5-serialbus qt5-scxml qt5-remoteobjects qt5-networkauth qt5-imageformats qt5-gamepad qt5-examples qt5-doc qt5-declarative qt5-datavis3d qt5-connectivity qt5-charts qt5-canvas3d qt5-3d pyside2 qt5-translations qt5-virtualkeyboard qt5-wayland qt5-webglplugin qt5-websockets qt5-webview
Comment by hamelg (hamelg) - Friday, 08 February 2019, 21:27 GMT
the same as patrick (potomac) : 5.12.1-2 doesn't fix the issue :(
Comment by patrick (potomac) - Sunday, 10 February 2019, 15:56 GMT
@hamelg : what graphic card do you use ?

I want to know if the problem of excessive ram consumption (when using oxygen theme) concerns radeon users (the workaround in Qt5 5.12.1-2 targets only nvidia users with the nouveau driver), and if this problem can be reproduced in virtualbox/qemu, with the gpu generic driver.
Comment by hamelg (hamelg) - Sunday, 10 February 2019, 18:03 GMT
NVIDIA Corporation GP108 [GeForce GT 1030]
I use the proprietary driver nvidia 415.27-4 with the oxygen theme.
Comment by patrick (potomac) - Sunday, 10 February 2019, 19:14 GMT
@hamelg : ok, so the bug (oxygen theme which triggers memory leak for plasmashell) affects both radeon and nivdia users,

currently I am trying a git bisect, in order to find the faulty commit, I will post the results
Comment by patrick (potomac) - Monday, 11 February 2019, 04:40 GMT
I did a git bisect and I manage to find the faulty commit, it's the commit :

[9d90c0edac91b35ec96646fd3e6cdd339639ca79] QImage: merge the size calculations with proper (non-UB) checks


If I revert this commit then the bug disapears, all is ok, no memory leak with oxygen theme,
I created a patch which reverts the faulty commit :


you can find as attachement a zip file which contains PKGBUILD and the patch, in order to rebuild qt5-base 5.12.1
Comment by Pavel (bartender) - Wednesday, 13 February 2019, 11:48 GMT
Today I updated everything: Qt 5.12.1, Plasma 5.15, Frameworks 5.55.
No problems with Breeze theme and nouveau driver.
Comment by patrick (potomac) - Wednesday, 13 February 2019, 14:06 GMT
a valgrind test has been made by an archlinux user and shows huge memory leak for plasmashell :

all packages (Qt5, plasmashell) are in the last release version
Comment by patrick (potomac) - Wednesday, 13 February 2019, 14:10 GMT
@Pavel : try your test with oxygen theme (reboot after the change, then reconnect to plasma), because the bug seems to occur mainly when the oxygen theme is used,

but there are also another conditions (perhaps graphic model card, 3D settings like openGL version, monitor resolution) to meet in order to have the massive memory leak of plasmashell
Comment by Atila Neves (atilaneves) - Thursday, 14 February 2019, 09:06 GMT
I can confirm that the bug is fixed in qt-base 5.12.1-2
Comment by Antonio Rojas (arojas) - Thursday, 14 February 2019, 09:10 GMT
Unfortunately this report has evolved into a messy mixture of two unrelated issues. Since the original issue (which affects nouveau users *only*) is fixed in 5.12.1-2, I'm going to go ahead and close this. Please keep the discussion about the other issue (OOM with some themes) in  FS#61741