Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#61634 - xkeyboard-config layout(s) broken after upgrade to 2.26

Attached to Project: Arch Linux
Opened by Cláudio Pereira (claudiop) - Tuesday, 05 February 2019, 04:27 GMT
Last edited by Andreas Radke (AndyRTR) - Saturday, 09 February 2019, 19:31 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 20
Private No

Details

xkeyboard-config 2.26 broke at least one layout (pt)

Don't know how to produce logs for this, but it should be very simple to reproduce.

1 - Upgrade from xkeyboard-config 2.25 to 2.26
2 - setxkbmap pt

You'll be greeted with:
Error loading new keyboard description

I tried other layouts and they worked, so I have no clue if the issue is exclusive to the pt one.

A workaround is to downgrade that package. 2.25 is fine.
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Saturday, 09 February 2019, 19:31 GMT
Reason for closing:  Fixed
Comment by João O. Santos (Joao-O-Santos) - Tuesday, 05 February 2019, 05:35 GMT
I filed the same bug just after you (I will delete it).

I did some digging and it seems upstream added a pt version for the colemak keyboard at the end of the file: usr/share/X11/xkb/symbols/pt
As it turns out the lines pertaining to the colemak keyboard add some `` and an unrelated line before the colemak configuration also had an weird value. One or both of those things were causing the layout to load. Changing them fixed the problem.
Applying the attached patch to that file should fix the problem.

I am not sure if this is an upstream bug or was somehow introduced by the build, as I'm not skilled enough to fully understand the program or the build process.
I humbly ask for your help with this issue.

Additional info:
* package version(s) 2.26-1
* config and/or log files etc. attached is a patch that fixes it when applied to the file usr/share/X11/xkb/symbols/pt

Steps to reproduce:
On a system with xkeyboard-config 2.26-1 run:
setxkbmap pt
   pt.patch (5.3 KiB)
Comment by somini (_somini_) - Tuesday, 05 February 2019, 14:16 GMT
I can confirm this bug, many thanks for that patch.

In case anyone else finds this, download that file and use:

$ patch /usr/share/X11/xkb/symbols/pt pt.patch
Comment by Xavier Francisco (Quatro) - Tuesday, 05 February 2019, 14:56 GMT
Can also confirm this issue.

Thanks for the patch! And thanks for saving me a trip to google to apply it :)
Comment by Andreas Radke (AndyRTR) - Tuesday, 05 February 2019, 16:16 GMT Comment by Francisco Pina (Stunts) - Tuesday, 05 February 2019, 22:06 GMT
I have just reported this bug upstream:
https://gitlab.freedesktop.org/daniel.sousa.me/xkeyboard-config/issues/1

I *think* gitlab is the the new "official" bug reporting location, but I was somewhat surprised that the gitlab repository is a few commits behind https://cgit.freedesktop.org ...
Comment by loqs (loqs) - Tuesday, 05 February 2019, 22:13 GMT Comment by André Rodrigues (Noboruu) - Wednesday, 06 February 2019, 10:36 GMT
On 2.26 I tried using pt layout, but also UK and ES and all malfunctioned, not sure if it's really something to do with that commit.
Comment by loqs (loqs) - Thursday, 07 February 2019, 21:51 GMT Comment by Andreas Radke (AndyRTR) - Friday, 08 February 2019, 17:21 GMT
Please try 2.26-2 in testing repo.
Comment by António Maia (stickmanChampion) - Friday, 08 February 2019, 23:03 GMT
Hello,

I am using the testing repo, no errors or bugs
Comment by Francisco Pina (Stunts) - Saturday, 09 February 2019, 02:10 GMT
Confirming that using `xkeyboard-config` 2.26-2 from [testing] fixes the issue.
Thank you, Andreas, for the very quick resolution!
Comment by Joao Fonseca (knaick) - Saturday, 09 February 2019, 17:24 GMT
Confirming that 2.26-2 works

Loading...