Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#61615 - [espeak-ng] haven't espeak api

Attached to Project: Community Packages
Opened by Alexander Epaneshnikov (erik_pro) - Sunday, 03 February 2019, 12:23 GMT
Last edited by Balló György (City-busz) - Tuesday, 09 April 2019, 23:29 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To No-one
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

if espeak-ng provides espeak it need to expose it's api.
ln /usr/bin/espeak-ng /usr/bin/espeak
ln -s /usr/include/espeak-ng/speak_lib.h /usr/include/espeak/speak_lib.h
ln -s /usr/lib/libespeak-ng.so.1 usr/lib/libespeak.so.1
ln -s usr/lib/libespeak-ng.so.1 usr/lib/libespeak.so

Steps to reproduce:
try to compile and run espeakup
This task depends upon

Closed by  Balló György (City-busz)
Tuesday, 09 April 2019, 23:29 GMT
Reason for closing:  Fixed
Additional comments about closing:  espeak-ng 1.49.2-5
Comment by Alexander Epaneshnikov (erik_pro) - Tuesday, 12 February 2019, 04:54 GMT
in regards to commit https://git.archlinux.org/svntogit/community.git/commit/trunk?h=packages/espeak-ng&id=74f13d68cb808be0d6dd3b5e2b43dd7416c0824c
I think this is not a correct approach. there a lot of programs witch required old espeak. and espeak-ng should provide api for them.

Loading...