Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#61579 - [tribler] Missing python2-pyopenssl dependency

Attached to Project: Community Packages
Opened by Bart Willems (hersenbeuker) - Wednesday, 30 January 2019, 15:52 GMT
Last edited by Balló György (City-busz) - Saturday, 30 March 2019, 08:52 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Filipe Laíns (FFY00)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Description:
Tribler misses the python2-pyopenssl dependency and is not able to start without it.

Additional info:
* package version: tribler 7.2.0_rc1-3

Steps to reproduce:
1. sudo pacman -S tribler
2. tribler # crashes
3. sudo pacman -S python2-pyopenssl
4. tribler # works
This task depends upon

Closed by  Balló György (City-busz)
Saturday, 30 March 2019, 08:52 GMT
Reason for closing:  Fixed
Additional comments about closing:  tribler 7.2.2-3
Comment by Marek Einla (mareke) - Thursday, 31 January 2019, 18:27 GMT
thank you.
Comment by grizzlyuser (grizzly) - Friday, 01 March 2019, 11:36 GMT
Moreover, when I install tribler on a system without any python stuff installed, and then install python2-pyopenssl it starts working, but still complains in the log about:

>:0: UserWarning: You do not have a working installation of the service_identity module: 'No module named service_identity'. Please install it from <https://pypi.python.org/pypi/service_identity> and make sure all of its dependencies are satisfied. Without the service_identity module, Twisted can perform only rudimentary TLS client hostname verification. Many valid certificate/hostname mappings may be rejected.

> ERROR:root: Fault Handler module not found.

After installation of the following two packages, I haven't noticed any complaints about missing modules in the log:

python2-service-identity
python2-faulthandler

BTW, python2-service-identity depends on python2-pyopenssl, so just adding python2-service-identity and python2-faulthandler to 'depends' of PKGBUILD looks like a fix to these issues.

Loading...