Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#61543 - [nvidia-dkms] doesn't need headers as dependency

Attached to Project: Arch Linux
Opened by RoundCube (RoundCube) - Saturday, 26 January 2019, 19:11 GMT
Last edited by Sven-Hendrik Haase (Svenstaro) - Wednesday, 11 March 2020, 18:12 GMT
Task Type Feature Request
Category Packages: Extra
Status Closed
Assigned To Sven-Hendrik Haase (Svenstaro)
Felix Yan (felixonmars)
Giancarlo Razzolini (grazzolini)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

nvidia-dkms has some (not all) kernel headers as optdependency

It doesn't need them as the "dkms" packages lists them already


It would be consistent with other dkms packages to remove them, same for virtualbox (separate ticket on cummunity tracker)
This task depends upon

Closed by  Sven-Hendrik Haase (Svenstaro)
Wednesday, 11 March 2020, 18:12 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed in trunk
Comment by Sven-Hendrik Haase (Svenstaro) - Wednesday, 12 February 2020, 11:41 GMT
@grazzolini: Thoughts on this?
Comment by Giancarlo Razzolini (grazzolini) - Wednesday, 12 February 2020, 13:30 GMT
Well, even though dkms has them, it might make sense to list on nvidia-dkms the headers for the kernels we know nvidia works on. Then again, I think that the nvidia driver works on all our official kernels.

So yes, let's drop it from the package.
Comment by Eli Schwartz (eschwartz) - Wednesday, 12 February 2020, 13:45 GMT
If it doesn't work for the kernel you have booted, not listing the -headers package as an optdepends won't actually inform users of it not working.
Comment by Giancarlo Razzolini (grazzolini) - Wednesday, 12 February 2020, 17:35 GMT
Yes, as far as I know, barred a few occasional issues with non compiling driver, it works on all of our official kernels. So, the listing of the headers done by the dkms package should be enough.
Comment by Eli Schwartz (eschwartz) - Wednesday, 12 February 2020, 17:54 GMT
My point is that even if you wanted to "list on nvidia-dkms the headers for the kernels we know nvidia works on" it would not actually have the desired effect. Users would not know that the list of kernels is anything other than an out of date, unmaintained duplicate of the same list in the "dkms" package itself.

It would anyways not be the correct way to inform users of Nvidia theoretically not working on a specific kernel (official or otherwise).

Loading...