FS#61538 - GNOME Settings stops starting suddenly

Attached to Project: Arch Linux
Opened by Calin Dan (calindan2013) - Saturday, 26 January 2019, 10:19 GMT
Last edited by Antonio Rojas (arojas) - Wednesday, 29 May 2019, 14:28 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To No-one
Architecture All
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 7
Private No


GNOME Settings stopped working suddenly without doing any changes to system

Additional info:
* GNOME 3.30.2
* [tmroland@localhost ~]$ gnome-control-center
Segmentation fault (core dumped)

[ 417.815532] traps: gnome-control-c[4639] general protection fault ip:7fd78d1ad8e2 sp:7ffcb95d0420 error:0 in libglib-2.0.so.0.5900.0[7fd78d183000+85000]

Jan 26 10:15:42 localhost kernel: audit: type=1701 audit(1548497742.769:143): auid=1000 uid=1000 gid=998 ses=3 pid=9976 comm="gnome-control-c" exe="/usr/bin/gnome-control-center" sig=11 res=1
#2 0x000055e82b426e44 n/a (gnome-control-center)
#3 0x000055e82b42c6db n/a (gnome-control-center)
#8 0x000055e82b45c279 n/a (gnome-control-center)
#12 0x000055e82b45a2c2 n/a (gnome-control-center)
#19 0x000055e82b459c5a cc_panel_list_set_active_panel (gnome-control-center)
#20 0x000055e82b45ecf0 n/a (gnome-control-center)
#24 0x000055e82b45b060 cc_window_new (gnome-control-center)
#25 0x000055e82b45ef2c n/a (gnome-control-center)
#33 0x000055e82b356359 main (gnome-control-center)
#35 0x000055e82b3563ae _start (gnome-control-center)

Steps to reproduce:

Default fresh arch install with nvidia 415.27 driver , Xorg + GNOME 3.30.2, just click settings and nothing happens and when done from terminal it shows segfault.
This task depends upon

Closed by  Antonio Rojas (arojas)
Wednesday, 29 May 2019, 14:28 GMT
Reason for closing:  Fixed
Additional comments about closing:  gnome 3.32
Comment by Calin Dan (calindan2013) - Saturday, 26 January 2019, 10:20 GMT
System: R5 2600X / 16 GB RAM / GTX 1080 / SSD / 1440p 144Hz display

Problem occurs on both Xorg and Wayland sessions.
Comment by mattia (nTia89) - Saturday, 26 January 2019, 11:17 GMT
Can't reproduce it on my system (i5-5200U).

Maybe a partial system update related issue?
Comment by Calin Dan (calindan2013) - Saturday, 26 January 2019, 12:05 GMT
no. I tried reinstalling all system packages including gnome using instructions from Arch Wiki Pacman Tips and Tricks, i rebooted and its exactly the same.
Comment by Evgeny (jeckhack) - Saturday, 26 January 2019, 16:12 GMT Comment by Calin Dan (calindan2013) - Saturday, 26 January 2019, 16:14 GMT
nothing to do with that, none of those things are happening to me. its just simply a segfault of control center.
Comment by Evgeny (jeckhack) - Saturday, 26 January 2019, 16:18 GMT
Try to rollback gtk3 to 3.24.3 and see if it fixes segfaults.
Comment by Calin Dan (calindan2013) - Saturday, 26 January 2019, 16:19 GMT
install via pacman?
Comment by Evgeny (jeckhack) - Saturday, 26 January 2019, 16:23 GMT Comment by Calin Dan (calindan2013) - Saturday, 26 January 2019, 16:39 GMT
Downgraded but problem still persists.
Comment by loqs (loqs) - Sunday, 27 January 2019, 22:00 GMT
If the issue is still present with gtk3 3.24.4+15+g80b5024239-1 please rebuild glib2 (and possibly gtk3) with debug symbols and provide and updated backtrace.
Comment by Yangtse Su (yangtsesu) - Monday, 11 March 2019, 07:07 GMT Comment by Jon Irving (j0ni) - Tuesday, 12 March 2019, 21:22 GMT
What @yangtsesu said.

Maybe a dupe of https://bugs.archlinux.org/task/61974

Comment by loqs (loqs) - Tuesday, 12 March 2019, 22:41 GMT
@yangtsesu and @j0ni how could glib2 2.60.0-1 which was created in March be the cause of an issue reported in January?
Comment by morealaz (morealaz) - Wednesday, 13 March 2019, 06:03 GMT
I have the same problem on two different freshly installed systems. It started after I try to open 'Details' tab in system setting. Before that system setting worked normally, but as soon as I try to open 'Datails' tab, it crashed and after that I always got segmentation fault. Reccently I install Arch again an I didn't open 'Details' tab and system setting worked normally without any segmentation fault, but I can not use 'Details' tab till this bug fixed.
Comment by Christopher Snowhill (kode54) - Wednesday, 13 March 2019, 07:58 GMT
Here's the upstream issue:


Upstream's official stance is that the fix, merged a month ago, is not worthy of a new stable release, so feel free to backport the patch to whatever stable release you're currently shipping.

The bug itself is using the wrong libgio free function on a structure that was very similar in name and shape to the actual structure that's being used, and the structure that it's expecting was recently changed by a glib2 update.

So, yeah, downgrade glib2, and wait for the gnome-control-center package maintainer to integrate upstream's patch into a release before upgrading glib2 again.
Comment by Jon Irving (j0ni) - Wednesday, 13 March 2019, 10:22 GMT
@loqs you make a very good point, I wasn't paying attention.

Would be good to get a comment from @calindan2013 to confirm if downgrading glib2 does not fix for them, to un-hijack this bug.
Comment by yurick gomes (yurick.gomes) - Thursday, 14 March 2019, 12:43 GMT
just copying the answer from here:

Run "gsettings reset org.gnome.ControlCenter last-panel" worked for me
Comment by Christopher Snowhill (kode54) - Friday, 15 March 2019, 04:15 GMT
I already reported that downgrading glib2 to January’s release works around the bug. Erasing the last-panel setting will only fix it until the next time you happen to click the Info panel, and also blocks you from accessing any of the panels nested underneath the Info panel, including the User profile settings. For instance, I wanted to change my account picture again, and don’t really want to do it manually.

There is an upstream patch from a month ago already fixing the issue, not by correcting the bug, but hy replacing the affected code with something completely different. This patch was not a candidate for a new stable release a month ago, but a new stable release is out as of yesterday, and it probably already contains that fix.

E: Damn, looks like gnome-control-center wasn't updated.

E2: Okay, I see an updated gnome-control-center is in the gnome-unstable repository.
Comment by Andrija (joaki97) - Saturday, 16 March 2019, 12:59 GMT
Test with updated Gnome, there's no problem for me with 3.32
Comment by loqs (loqs) - Saturday, 16 March 2019, 17:22 GMT
@yurick.gomes @kode54 and @joaki97 you do realize the initial bug report was about an issue in gnome-control-center 3.30.2-1 and glib2 2.58.3-1 from January?
Comment by Andrija (joaki97) - Saturday, 16 March 2019, 17:31 GMT
Honestly, I tried to open gnome-settings 2 days before 3.32 release and it crashed. I don't know how long gnome-settings were unusable on my PC.