Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#61533 - [zsh][5.7] VCS_INFO_detect_p4:79: maximum nested function level reached; increase FUNCNEST? on start

Attached to Project: Arch Linux
Opened by Frederic Bezies (fredbezies) - Friday, 25 January 2019, 18:58 GMT
Last edited by Pierre Schmitz (Pierre) - Sunday, 27 January 2019, 09:16 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Pierre Schmitz (Pierre)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description: Since I upgraded zsh to version 5.7-1 I got this error on start:

VCS_INFO_detect_p4:79: maximum nested function level reached; increase FUNCNEST?

I'm using zsh + grml-zsh-config.

Additional info:
zsh 5.7-1
grml-zsh-config 0.15.3-1

Steps to reproduce:

Use zsh with grml-zsh-config and update zsh to version 5.7-1. And see...
This task depends upon

Closed by  Pierre Schmitz (Pierre)
Sunday, 27 January 2019, 09:16 GMT
Reason for closing:  Fixed
Comment by Frederic Bezies (fredbezies) - Friday, 25 January 2019, 19:00 GMT
Of course, downgrading zsh works and this error message disappears...
Comment by Frederic Bezies (fredbezies) - Friday, 25 January 2019, 19:03 GMT
Related to this modification?

You can read on http://zsh.sourceforge.net/releases.html

vcs_info git: The gen-unapplied-string hook receives the patches in order (next to be applied first). This is consistent with the hg backend and with one of two contradictory claims in the documentation (the other one has been corrected). In zsh through 5.6.2, the patches were passed in reverse order, next to be applied being last in the array. The gen-applied-string hook is unaffected; it still receives the patches in reverse order, from last applied to first applied.
Comment by Frederic Bezies (fredbezies) - Saturday, 26 January 2019, 07:53 GMT
I generated an archlinux installation ISO with testing repositories enabled. Booted it in VirtualBox. I faced once again this bug :(

See attached screenshot. Looks like zsh 5.7 is kinda broken with grml-zsh enabled. I will try asap with a "naked" zsh.
Comment by KriK (krik) - Saturday, 26 January 2019, 09:27 GMT
Same problem on 2 machines
Comment by Pedro Gabriel Drumond Pereira (pedrogabriel) - Saturday, 26 January 2019, 20:05 GMT
Same problem here.
Comment by Pierre Schmitz (Pierre) - Sunday, 27 January 2019, 07:54 GMT
The issue was addressed upstream: http://www.zsh.org/mla/workers//2019/msg00058.html

I have applied the patch and released zsh-5.7-2. This should fix the issue.
Comment by Frederic Bezies (fredbezies) - Sunday, 27 January 2019, 09:12 GMT
Indeed, it is fixed. No more VCS-INFO... when opening a TTY or a terminal emulator. Thanks!

Loading...