Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#61526 - [gtk3] 3.24.4, nvidia - gnome-shell crash

Attached to Project: Arch Linux
Opened by Evgeny (jeckhack) - Thursday, 24 January 2019, 21:55 GMT
Last edited by Jan Steffens (heftig) - Sunday, 27 January 2019, 16:49 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Jan Steffens (heftig)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:

Hi. My gnome shell crashes when opening gnome-control-center or gnome tweaks with screen becoming a colored mess and lots of errors in journalctl, like nvidia Xid errors, libinput, pango etc etc. After reverting gtk3 to 3.24.3 everything works as intended, as far as I can tell. This is on clean install made 3 hours ago.

Haswell i3
gtx 960 with latest proprietary driver, gnome on xorg.

journalctl log attached

Additional info:
* package version(s)
* config and/or log files etc.


Steps to reproduce:
This task depends upon

Closed by  Jan Steffens (heftig)
Sunday, 27 January 2019, 16:49 GMT
Reason for closing:  Fixed
Additional comments about closing:  gtk3 3.24.4+15
Comment by Evgeny (jeckhack) - Thursday, 24 January 2019, 22:08 GMT
Log from another boot.
Comment by loqs (loqs) - Thursday, 24 January 2019, 22:22 GMT
There are not many commits between 3.24.3 and 3.24.4 https://gitlab.gnome.org/GNOME/gtk/commits/gtk-3-24
The cause of all the pango output might be https://gitlab.gnome.org/GNOME/gtk/commit/ed39721aa7435860f46da69998cf6cac4ae7e735
Can you try reverting that commit and seeing if it resolves the issue?
Comment by German Rios (germanlokura) - Thursday, 24 January 2019, 22:28 GMT
Something similar happened to me, but with kde. I realized that by changing the settings in system preferences -> screen and monitor -> composer. Changing there to Xrender solved the problems that the whole screen was pixelated. I hope it helps you. Sincerely.
Comment by Evgeny (jeckhack) - Thursday, 24 January 2019, 22:36 GMT
Building gtk3 with git revert -n ed39721aa7435860f46da69998cf6cac4ae7e735. I'll post back ASAP.
Comment by Evgeny (jeckhack) - Thursday, 24 January 2019, 23:07 GMT
Ok, done. Tested for a few minutes, it isn't crashing anymore. Log attached.
Comment by Evgeny (jeckhack) - Saturday, 26 January 2019, 07:42 GMT
I can't find any mentioning of this behavior for the last week in google. It just can't be so much hardware specific. Did anybody reproduce this issue? At least comment please. Else I feel like unluckiest man in arch community right now :)
Comment by Evgeny (jeckhack) - Sunday, 27 January 2019, 11:54 GMT
Tested with gtk3 from repos after latest kernel and nvidia update. This is what happens. You can see screen corruption and pango errors on the screenshot.
Comment by Evgeny (jeckhack) - Sunday, 27 January 2019, 12:03 GMT
This is with gnome-tweaks. Btw I can't click any buttons in gnome tweaks window. It's like adwaita is freaking out.
Comment by loqs (loqs) - Sunday, 27 January 2019, 12:30 GMT Comment by Evgeny (jeckhack) - Sunday, 27 January 2019, 12:51 GMT
Dear loqs, your suggestion gave me an idea. I installed noto-fonts and the problem seems to be solved at first glance. It's like this bug is about those I\O letters on gtk window switches, It seems like (after 3.24.4 update) if system can't find appropriate font for these goddamn swithes, it freaks out and causes all sorts crashes (unbeliveable!) Previously I had only cantarell-fonts and ttf-liberation installed (and source-code-pro for terminal).
Comment by Evgeny (jeckhack) - Sunday, 27 January 2019, 12:53 GMT
Cantarell, I mean cantarell, not croscore.
Comment by Evgeny (jeckhack) - Sunday, 27 January 2019, 12:55 GMT
Could you try to reproduce the issue if you happen to have gnome installed?
Comment by loqs (loqs) - Sunday, 27 January 2019, 13:01 GMT
I have gtk3 and some parts of gnome required by cinnamon but I do not have gnome-shell installed. I do have noto-fonts installed.
The commits I referenced as you realized provide the symbols instead of requiring a font to supply them which is causing the issue on your system.
Comment by Evgeny (jeckhack) - Sunday, 27 January 2019, 13:03 GMT
I will try https://gitlab.gnome.org/GNOME/gtk/commit/6a4ce55a69c5ecbbf06bc905ac0bfdd04f64bb66 without noto-fonts and report back ASAP, just to be sure.
Comment by Evgeny (jeckhack) - Sunday, 27 January 2019, 13:38 GMT
So, as I expected.
To fix this bug, there are 2 solutions. To add https://gitlab.gnome.org/GNOME/gtk/commit/6a4ce55a69c5ecbbf06bc905ac0bfdd04f64bb66 in gtk3 (resulted screenshot attached as 1.png)

OR to add some font with:

"⏽", /* U+23FD POWER ON SYMBOL */
"❙", /* U+2759 MEDIUM VERTICAL BAR */
"⭘", /* U+2B58 HEAVY CIRCLE */
"○", /* U+25CB WHITE CIRCLE */

to runtime dependency (like noto-fonts). Resulted screenshot attached as 2.png

I realise that a lot of people have some additional fonts installed on their systems, but in case you have only cantarell (gnome dep) and liberation (dep of choice for chromium, aka "any ttf font"), gnome will eat your face and make you think that your gpu fried.


   1.png (1.03 MiB)
   2.png (823.1 KiB)

Loading...