Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#61485 - [dbus] Unexpanded AX_ macro found when building dbus

Attached to Project: Arch Linux
Opened by John Unland (junland) - Monday, 21 January 2019, 02:51 GMT
Last edited by Jan Alexander Steffens (heftig) - Wednesday, 13 February 2019, 20:32 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Jan de Groot (JGC)
Jan Alexander Steffens (heftig)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:

When building dbus (During the prepare() step), build fails with an error message "Unexpanded AX_ macro found...." (See attached error_msg.txt for full output.).

Additional info:

* Full output of build is in the attached file under error_msg.txt
* This error seems to be plaguing Gentoo as well, see https://bugs.gentoo.org/674830
* autoconf version is 2.69
* dbus version is 1.12.12
* Build fails during the prepare() step as stated above.
* dbus PKGBUILD is here: https://git.archlinux.org/svntogit/packages.git/tree/trunk/PKGBUILD?h=packages/dbus

Steps to reproduce:

1. Grab dbus PKGBUILD.
2. Change directory into the dbus package.
3. Run makepkg.
$> makepkg --syncdeps --skippgp
4. Error should present itself within a couple of seconds.
This task depends upon

Closed by  Jan Alexander Steffens (heftig)
Wednesday, 13 February 2019, 20:32 GMT
Reason for closing:  Upstream
Comment by Eli Schwartz (eschwartz) - Monday, 21 January 2019, 03:37 GMT
Comment by Jan Alexander Steffens (heftig) - Wednesday, 13 February 2019, 20:32 GMT
This has been fixed upstream in https://gitlab.freedesktop.org/dbus/dbus/commit/6ef67cff6ba26645f9cbe23ffb401f3d49a66429

I see no need to rebuild the package; this can wait until the next dbus release.

Loading...