Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#61441 - iwlwifi dies in linux-4.20.2.arch1-1

Attached to Project: Arch Linux
Opened by Svenne Krap (svenne_k) - Thursday, 17 January 2019, 08:25 GMT
Last edited by Laurent Carlier (lordheavy) - Tuesday, 02 July 2019, 20:00 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To No-one
Architecture x86_64
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description: iwlwifi dies in linux-4.20.2.arch1-1


Additional info:
* linux-4.20.2.arch1-1
* X1 Yoga Gen1
* 04:00.0 Network controller: Intel Corporation Wireless 8260 (rev 3a)


Steps to reproduce:
1) Install kernel
2) Reboot
3) No wifi

Dmesg attached.

Has been tried through multiple reboots.

Downgrading to linux-4.20.1.arch1-1 fixes problem instantly.
This task depends upon

Closed by  Laurent Carlier (lordheavy)
Tuesday, 02 July 2019, 20:00 GMT
Reason for closing:  Fixed
Comment by Svenne Krap (svenne_k) - Thursday, 17 January 2019, 08:41 GMT
Dmesg
Comment by Jack Random (jackrandom) - Thursday, 17 January 2019, 10:24 GMT
similar here, downgrading to 4.20.1-arch1-1 restores previous working state.

card: Intel Corporation Wireless-AC 9260 (rev 29)
board: dell latitude laptop

wifi still works, but unusual alternating ping times.

Can't see any commits for iwlwifi though:
https://cdn.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.20.2

// UPDATE:
wifi breaks frequently.
also, same with 4.20.3 :(
Comment by Svenne Krap (svenne_k) - Thursday, 17 January 2019, 13:48 GMT
Same problem in 4.20.3.arch1-1
Comment by Dan Martins (dmartins) - Saturday, 19 January 2019, 03:21 GMT
Svenne,
Could you report this upstream to https://bugzilla.kernel.org/ ? It doesn't look like something Arch specific - we have almost no change to the kernel package between 4.20.1 and 4.20.2.
They will likely want:
full dmesg from both kernels
cat /proc/config.gz from both kernels
lspci -vv for your wifi card

Jack,
Yours looks like a different issue. Although it may also be better reported upstream, it does look like you aren't using the latest firmware. Please make sure your linux-firmware package is up to date.
Comment by loqs (loqs) - Saturday, 19 January 2019, 10:57 GMT
I would suggest bisecting between 4.20.2 and 4.20.1 which should involve one full kernel build and approximately 6 smaller builds (this includes bulding 4.20.1 and 4.20.2 locally)
Comment by Pablo (Ona) - Sunday, 20 January 2019, 22:43 GMT
Same problem here with 4.20.2 and 4.20.3, iwlwifi fails (dmesg shows STATISTICS_CMD times out, sometimes it's another variable).

I'm on a Thinkpad T470, wifi card Intel Dual Band Wireless-AC 8265.

Downgrading to 4.20.1 or less solves the problem again.

Edit: Sorry if there is no reason to post it here as it was clearly said it's a kernel problem, not Arch's.
Comment by Jack Random (jackrandom) - Monday, 21 January 2019, 10:26 GMT
I'm trying to debug things here. @all Which firmware version is loaded in your cases?

for me, it's
iwlwifi 0000:01:00.0: Loaded firmware version: 41.fc1a7aea.0

while newest for this card would be usr/lib/firmware/iwlwifi-9260-th-b0-jf-b0-43.ucode, which is also included in latest linux-firmware package from core.

which firmware is loaded, depends on the config in kernel, see this diff
https://github.com/torvalds/linux/commit/e69fbf31ca2cf6d6a2afedd0f8b30dcd10e76049#diff-25a6cc8daadea7002e63790ffea696c0 :
#define IWL9000_UCODE_API_MAX 43

so it seems for me like, in kernel 4.21 newest (43) should be loaded.

I'm now trying to find out if it's possible to force-load a firmware file and if this helps.
Comment by Svenne Krap (svenne_k) - Monday, 21 January 2019, 10:29 GMT
I have
iwlwifi 0000:04:00.0: Loaded firmware version: 36.9f0a2d68.0

Wierdly enough, now it works for me again (with kernel 4.20.3-arch1-1-ARCH)

Comment by Pablo (Ona) - Monday, 21 January 2019, 14:18 GMT
Same here for 8265 as Svenne with 8260: iwlwifi 0000:04:00.0: loaded firmware version 36.9f0a2d68.0

As I read on https://wireless.wiki.kernel.org/en/users/drivers/iwlwifi/core_release , our cards doesn't update their firmware since 36, so it seems we can't update there. I tried mannualy updating the driver and nothing.

It also "works" for me in 4.20.3, but I have to turn it on and off several times in settings to make it work. Maybe a NetworkManager issue instead?
Comment by Jack Random (jackrandom) - Tuesday, 22 January 2019, 10:31 GMT
for me I don't have any problems anymore since kernel 5.0-rc3. (i.e. linux-mainline from AUR / archlinuxcn)

also, check if you have any options for iwlwifi in modprobe.d (i.e. energy saving) and try without.
Comment by Daniel Biro (archbox) - Tuesday, 25 June 2019, 10:16 GMT
No idea if you still have this problem, but as Jack Random said, I suspect that it's the energy saving feature that messes up your wifi. Run: "iw wlan0 get power_save", and if it says on, do "iw wlan0 set power_save off". It solved it for me (also don't forget to use your own interface name instead of wlan0).

Loading...