Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#61424 - [wine-mono] mono isn't installed in wine

Attached to Project: Community Packages
Opened by CS (cskau) - Wednesday, 16 January 2019, 08:28 GMT
Last edited by Filipe Laíns (FFY00) - Saturday, 06 April 2019, 16:25 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Felix Yan (felixonmars)
Filipe Laíns (FFY00)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 4
Private No

Details

Installing wine-mono doesn't seem to install mono in wine.

From prodding around a bit it looks like the package is downloading the installer, but mono itself is never installed in wine.

The package puts the installer at:
/usr/share/wine/mono/wine-mono-4.7.5.msi

What I observed was I installed wine and wine-mono:
pacman -S wine wine-mono
I then expected I'd be able to run a mono binary:
wine my_dot_net_bin.exe
But what I encountered was:
0009:err:mscoree:CLRRuntimeInfo_GetRuntimeHost Wine Mono is not installed

I found that I could manually install mono with the installer, which fixes the issue:
wine msiexec /i /usr/share/wine/mono/wine-mono-4.7.5.msi


My expectation as a user however is that installing wine-mono will install mono in wine.
This task depends upon

Closed by  Filipe Laíns (FFY00)
Saturday, 06 April 2019, 16:25 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Works as expected. We can't install it via the system package because the default wine prefix, which you are using, is present in your user folder. Even if it wasn't it doesn't make any sense installing it as the installation wouldn't propagate if you created other wine prefix. I suggest you learn a bit more about how wine works, I don't currently have the time to explain this properly.

Loading...