Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#61394 - [mongodb] latest version is not AGPLv3

Attached to Project: Community Packages
Opened by Pierce Lopez (ploxiln) - Monday, 14 January 2019, 06:53 GMT
Last edited by Felix Yan (felixonmars) - Monday, 21 January 2019, 19:04 GMT
Task Type General Gripe
Category Packages
Status Closed
Assigned To Felix Yan (felixonmars)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

The mongodb package for 4.0.5 claims that the license is AGPLv3.
mongodb-4.0.3 was the last version to be offered under the AGPLv3.
Current versions are offered under the "Server Side Public License".
By the way, the SSPL is not approved by the FSF or OSI.
This task depends upon

Closed by  Felix Yan (felixonmars)
Monday, 21 January 2019, 19:04 GMT
Reason for closing:  None
Additional comments about closing:  mongodb dropped from [community].
Comment by Pierce Lopez (ploxiln) - Monday, 14 January 2019, 06:55 GMT
Forgot some helpful links:
https://github.com/mongodb/mongo/blob/r4.0.5/LICENSE-Community.txt

MongoDB is free and open-source. Versions released prior to October 16,
2018 are published under the AGPL. All versions released after October
16, 2018, including patch fixes for prior versions, are published under
the Server Side Public License (SSPL) v1. See individual files for details.

(from https://github.com/mongodb/mongo/blob/r4.0.5/README)
Comment by Eli Schwartz (eschwartz) - Monday, 14 January 2019, 07:31 GMT
  • Field changed: Task Type (Bug Report → General Gripe)
  • Field changed: Status (Unconfirmed → Assigned)
  • Field changed: Severity (Medium → Low)
  • Task assigned to Felix Yan (felixonmars)
Neither the FSF nor the OSI are required to approve of it BTW, as long as the legal argument can be successfully defended that the software does not violate the license of anything it uses.

Although the discussion by the OSI seems to be still ongoing, so they haven't exactly disapproved it either.
Comment by Pierce Lopez (ploxiln) - Monday, 14 January 2019, 07:35 GMT
... and there is proprietary software packaged by Arch Linux for convenience, like nvidia binary drivers, so I agree we would not remove mongodb in any case

Loading...