Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#61393 - [totel-plparser] - libquvi should be an optional dependecy

Attached to Project: Arch Linux
Opened by Torben Andresen (tapsiturtle) - Monday, 14 January 2019, 06:39 GMT
Task Type General Gripe
Category Packages: Extra
Status Unconfirmed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 0
Private No

Details

Hi,

upstream says that libquvi is an optional dependency. And if i understand the libquive page correct, it is just for Flash streams. As there is fewer and fewer Flash content in the web, could you make libquvi set as optional dependency? Also the libquvi project seems to be dead and so users can decide not to install it. Thanks.
This task depends upon

Comment by Jan de Groot (JGC) - Tuesday, 15 January 2019, 12:24 GMT
It's an optional dependency at compile time. When the binary is compiled, stuff links to libquvi. The linking is limited to a helper program, but I guess error logs will be full of "failed loading shared library libquvi.so" messages when someone tries to play a flash stream.
Comment by Torben Andresen (tapsiturtle) - Friday, 18 January 2019, 11:19 GMT
So the only way that it is not needed anymore is that upstream changes it's code, right?

Loading...