Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#61358 - [pcre][mariadb] MariaDB can't be built with pcre

Attached to Project: Arch Linux
Opened by RoundCube (RoundCube) - Friday, 11 January 2019, 21:21 GMT
Last edited by Andreas Radke (AndyRTR) - Tuesday, 10 December 2019, 13:22 GMT
Task Type Bug Report
Category Packages: Extra
Status Assigned
Assigned To Christian Hesse (eworm)
Architecture All
Severity Very Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 0
Private No

Details

I am currently investigating how to best build MariaDB 10.3 for Arch.

It turned out that pcre has an bug, due to which MariaDB can't use it.
It's currently worked around in the MariaDB package by using a bundled pcre version which has been patched.

The upstream report is here, they agreed it's a bug, but they don't work anymore on the pcre1 version (the 8.x series)
At the end is the patch, with which one can successfully build MariaDB.

https://bugs.exim.org/show_bug.cgi?id=2173

We could apply the patch to the pcre package, or continuing to work around it by shipping MariaDB with the bundled pcre.

Additional info:
* pcre 8.42
This task depends upon

Comment by RoundCube (RoundCube) - Friday, 11 January 2019, 22:25 GMT
What I forgot to mention: Compiling pcre with -O0 leads as well to correct behaviour.
Comment by loqs (loqs) - Tuesday, 08 September 2020, 14:41 GMT
[1] is marked fixed in 10.5.1 so the current mariadb package should be able to use the system supplied pcre2 if desired.

[1] https://jira.mariadb.org/browse/MDEV-14024

Loading...