Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#61353 - [ejabberd] ejabberd.service fails to start

Attached to Project: Community Packages
Opened by awhan patnaik (awhan) - Friday, 11 January 2019, 12:31 GMT
Last edited by Sergej Pupykin (sergej) - Monday, 17 June 2019, 13:33 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Sergej Pupykin (sergej)
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

Below is output after attempting to start the service. It takes some time for the error report.

=======================================
$ sudo systemctl start ejabberd.service
[sudo] password for m:
Job for ejabberd.service failed because the control process exited with error code.
See "systemctl status ejabberd.service" and "journalctl -xe" for details.
=========================================================================

Checking the status of the service I see that multiple crash dumps are written to /var/log/ejabberd/

======================================
$ sudo systemctl status ejabberd.service
● ejabberd.service - XMPP Server
Loaded: loaded (/usr/lib/systemd/system/ejabberd.service; disabled; vendor preset: disabled)
Active: activating (start) since Fri 2019-01-11 17:50:12 IST; 4s ago
Cntrl PID: 28807 (ejabberdctl)
Tasks: 2 (limit: 4915)
Memory: 4.2M
CGroup: /system.slice/ejabberd.service
├─28807 /bin/sh /usr/bin/ejabberdctl started
└─28929 sleep 2

Jan 11 17:50:12 zero systemd[1]: Starting XMPP Server...
Jan 11 17:50:16 zero sh[28807]: init terminating in do_boot ({undef,[{ejabberd_ctl,start,[],[]},{init,start_em,1,[]},{init,do_boot,3,[]}]})
Jan 11 17:50:16 zero sh[28807]: [1B blob data]
Jan 11 17:50:16 zero sh[28807]: Crash dump is being written to: /var/log/ejabberd/erl_crash_20190111-175012.dump...done
=======================================================================================================================

Additional info:
* ejabberd 18.12.1-1
* Linux zero 4.20.0-arch1-1-ARCH #1 SMP PREEMPT Mon Dec 24 03:00:40 UTC 2018 x86_64 GNU/Linux

Steps to reproduce:
1 sudo systemctl start ejabberd.service

Attaching one of the crash dumps.
This task depends upon

Closed by  Sergej Pupykin (sergej)
Monday, 17 June 2019, 13:33 GMT
Reason for closing:  Works for me
Comment by Sergej Pupykin (sergej) - Friday, 24 May 2019, 08:45 GMT
Currently it works for me. Can it be reproduced now?

Loading...