Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#61328 - udev 240 not recognising keyboard

Attached to Project: Arch Linux
Opened by larsko (larsko) - Wednesday, 09 January 2019, 19:43 GMT
Last edited by Dave Reisner (falconindy) - Sunday, 13 January 2019, 16:17 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To No-one
Architecture All
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 18
Private No

Details

Description:

After upgrading to udev 240, the keyboard is no longer recognised during boot. This prevents me from booting as I have an encrypted root disk and need to enter the password during boot. The same problem occurs when booting into a rescue shell -- keyboard input is not recognised. I've tried the normal and fallback initramfs images, internal and external USB keyboards. With debug enabled, I get a message about the keyboard being locked; this goes away when booting with i8042.unlock=1 but this doesn't fix the problem. No other suspicious debug messages -- keyboard is recognised by the kernel. Downgrading to udev 239 fixes the issue.

Additional info:
* package version(s)
* config and/or log files etc.

Hardware: Dell XPS 13 9350.


Steps to reproduce:
- Install idev 240.
- Boot.
This task depends upon

Closed by  Dave Reisner (falconindy)
Sunday, 13 January 2019, 16:17 GMT
Reason for closing:  Fixed
Additional comments about closing:  core/systemd-240.34-2
Comment by Simon Eamonny (n0m1s) - Thursday, 10 January 2019, 15:16 GMT
Same problem here on a Dell Precision 7520.
External keyboards work fine (once I added the "keyboard" hook *before* the "autodetect" hook in mkinitcpio.conf), but the internal keyboard does not work.
Downgrading to Systemd-239.370-1 fixed the internal keyboard.
Comment by Dave Reisner (falconindy) - Thursday, 10 January 2019, 15:32 GMT Comment by Simon Eamonny (n0m1s) - Thursday, 10 January 2019, 15:40 GMT
The bug is still present with these packages.
Comment by wzrd tales (wzrdtales) - Thursday, 10 January 2019, 17:55 GMT
Same problem here, lenovo t580, but also attaching multiple other keyboards externally (usb) doesn't help.
Comment by kongsovs (kongsovs) - Thursday, 10 January 2019, 18:07 GMT
Same problem for me.
Im using a Lenovo Thinkpad P52.
External keyboards work fine without needing the autodetect changes.
Comment by Mathias Anselmann (matse) - Thursday, 10 January 2019, 18:59 GMT
Similar Problem here with this update, on my Lenovo X1 the internal keyboard is not using when I boot and have to enter the password for the encrypted root device. I have to plug in my USB keyboard (which was plugged in when creating the initramfs) to be able to enter my password. The "keyboard" hook is before the autodetect hook and before this update I was able to use both, internal or external keyboard.

//EDIT:
Just tested the packages falconindy posted (systemd 240.156-1) and with these both keyboards work again!
Comment by Eugene (jdevelop) - Thursday, 10 January 2019, 23:43 GMT
Got the same problem - LUKS prompt but no keyboard ( GRUB is okay).

Was able to fix that by adding modules:


MODULES="i915 bbswitch i8042 atkbd serio serio_raw"

System boots up reliably, I can unlock LUKS root volume just fine.

pacman -Q | grep systemd
lib32-systemd 240.0-1
libsystemd 240.0-3
systemd 240.0-3
systemd-sysvcompat 240.0-3
Comment by Aaron Barany (akb825) - Friday, 11 January 2019, 01:08 GMT
I came here after seeing  FS#61334  being marked as a duplicate of this. My desktop cannot boot with systemd-240, since it will fail to mount the root partition, which is located on an internal SATA SSD, and booting with legacy BIOS.

Downgrading to systemd-239 got my system booting again. @falconindy the packages you provide do not resolve the issue.
Comment by Dave Reisner (falconindy) - Friday, 11 January 2019, 01:30 GMT
This is likely https://github.com/systemd/systemd/issues/11314 upstream. Please continue discussion there and help bisect if you can.
Comment by Dave Reisner (falconindy) - Friday, 11 January 2019, 13:16 GMT
As a workaround, you should be able to use systemd in your initramfs to avoid the upstream bug. There's a pending set of fixes which will probably be merged soon.
Comment by Brandon (hashstat) - Friday, 11 January 2019, 20:08 GMT
Adding 'atkbd' to MODULES in /etc/mkinitcpio.conf and running `sudo mkinitcpio -p linux` solved the issue for me.
Comment by Obs (obspm) - Saturday, 12 January 2019, 08:31 GMT
Same problem here (Dell XPS13 too), but find a workaround, when ask the password, just press enter (very weird why enter is working), but after at the second time keyboard working.
Comment by Dave Reisner (falconindy) - Saturday, 12 January 2019, 15:14 GMT
systemd-240.34-2 should resolve the problems mentioned here. If you're still affected, please mention what your initramfs HOOKS are and post your kernel commandline.

Loading...