Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#61272 - [wpa_supplicant] 2.7 / Wifi dead

Attached to Project: Arch Linux
Opened by Rico Beier (beiri22ny) - Friday, 04 January 2019, 12:09 GMT
Last edited by Andreas Radke (AndyRTR) - Tuesday, 10 December 2019, 12:57 GMT
Task Type Bug Report
Category Packages: Core
Status Assigned
Assigned To Bartłomiej Piotrowski (Barthalion)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 3
Private No

Details

Description:

I just upgraded to wpa_supplicant 2.7; and my wifi stopped working.
The message was "deauthenticating by local choice, reason=1 unknown).

Downgrading to wpa_supplicant 2.6.12 fixed the problem.

My Card: (lshw)
*-network
description: Wireless interface
product: Centrino Advanced-N 6230 [Rainbow Peak]
vendor: Intel Corporation
physical id: 0
bus info: pci@0000:03:00.0
logical name: wlp3s0
version: 34
serial: 88:53:2e:0e:0a:29
width: 64 bits
clock: 33MHz
capabilities: bus_master cap_list ethernet physical wireless
configuration: broadcast=yes driver=iwlwifi driverversion=4.20.0-arch1-1-ARCH firmware=18.168.6.1 ip=192.168.1.173 latency=0 link=yes multicast=yes wireless=IEEE 802.11
resources: irq:37 memory:f1b00000-f1b01fff
This task depends upon

Comment by Rico Beier (beiri22ny) - Friday, 04 January 2019, 12:11 GMT
Kernel 4.20.0-arch1-1-ARCH
Comment by Eric Gediman (Idontunderstandwhatiamdoing) - Saturday, 05 January 2019, 01:31 GMT
I can confirm this. I had the same issue and downgrading to 2.6.12 fixes the problem. It seems to only affect certain routers, as a hotspot worked while my home router did not. Repeatedly trying to connect to my home router also caused the router to crash and reset. I also got an error message of "deauthenticating by local choice, reason=1 unknown.

My Card (lshw):
*-network
description: Wireless interface
product: Wireless 8265 / 8275
vendor: Intel Corporation
physical id: 0
bus info: pci@0000:04:00.0
logical name: wlp4s0
version: 78
serial: bc:a8:a6:fe:06:ff
width: 64 bits
clock: 33MHz
capabilities: bus_master cap_list ethernet physical wireless
configuration: broadcast=yes driver=iwlwifi driverversion=4.20.0-arch1-1-ARCH firmware=36.9f0a2d68.0 ip=192.168.0.9 la$
802.11
resources: irq:129 memory:df100000-df101fff
Comment by Christoph (cobzcs) - Tuesday, 08 January 2019, 09:32 GMT
I was also affected by this issue (same wireless-card as Eric). I also downgraded to wpa_supplicant 2.6 and it was working again. But now (since new years eve) it is also working with wpa_supplicant 2.7. Maybe there was a version dependency missing? Does this problem still exists for you?

Loading...