Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#61256 - [linux] 4.20 startup issues

Attached to Project: Arch Linux
Opened by Reiner Zufall (Phoen7x) - Thursday, 03 January 2019, 00:26 GMT
Last edited by Andreas Radke (AndyRTR) - Tuesday, 10 December 2019, 12:55 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To Jan Alexander Steffens (heftig)
Architecture x86_64
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
Since the update to v 4.20, the boot process stops while starting various services (see picture) and does nothing more.
Last line either
[OK] Started Hostname Service. or
[OK] Started Network Manager Skript Dispatcher Service.

Additional info:
* package version: 4.20.arch1-1
* config and/or log files etc.: /proc/sys/kernel/random/entropy_avail 2113


Steps to reproduce:
Hardware: Lenovo Thinkpad E485 (Ryzen5 2500U), 8GB RAM, with kernelparameter: ivrs_ioapic[32]=00:14.0 pci=noaer

After downgrading the kernel to latest v. 4.19.8 with
pacman -U linux.4.19.8.arch1-1_tar.xz tp_smapi.xx.tar.xz
the system starts back to normal.
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Tuesday, 10 December 2019, 12:55 GMT
Reason for closing:  Fixed
Comment by raneon (raneon) - Thursday, 03 January 2019, 18:55 GMT
I did today as well the update on the HP Envy x360 15 (Ryzen 2500U) and Linux freezes during modeset. Deactivating modesetting with the kernel parameter "nomodeset" allowed me to install linux-lts 3.19.13 and it works fine. So something must be wrong with Linux 4.20 or does it require new firmware?
Comment by AK (Andreaskem) - Thursday, 03 January 2019, 19:25 GMT
I have the exact same laptop (but with 16 GiB RAM) and do not experience this issue. However, I have provided amd_iommu=off on the kernel command line since I got this thing. Every now and then I try to remove this option but it refuses to boot without it. As far as I know, there are some alternative options (like the one you are using, I guess) that would have worked, too.

(I am running the latest firmware version 1.48 from late December, by the way)
Comment by loqs (loqs) - Thursday, 03 January 2019, 21:23 GMT
What kernel messages were recorded in the journal from an affected boot? Please also post the same messages from an unaffected boot for comparison.
Comment by Reiner Zufall (Phoen7x) - Thursday, 03 January 2019, 21:43 GMT
Archlinux wiki says amd_iommu=pt @Andreaskem did you testet this? Is this your only kernel parameter? https://wiki.archlinux.org/index.php/Laptop/Lenovo#E_series

Maybe something changes in 4.20, why a different kernel parameter is required?
Comment by Mariusz Mikołajczak (flak999) - Thursday, 03 January 2019, 22:20 GMT
I had this same issue as reporter. I can confirm changing amd_iommu=pt to amd_iommu=off resolves this problem, and 4.20.0 is working.
Comment by loqs (loqs) - Thursday, 03 January 2019, 22:25 GMT Comment by German Rios (germanlokura) - Friday, 04 January 2019, 06:30 GMT
I have the same problem. The screen freezes. Also when connecting the computer with a smarttv. The screen is all pixilated. I have noticed that the error also occurs when opening firefox and thunderbird. I have samsung monitor. Motherboard asus.
Comment by Reiner Zufall (Phoen7x) - Friday, 04 January 2019, 18:20 GMT
For me adding only these kernel parameters solves the problem:
amd_iommu=off ivrs_ioapic[32]=00:14.0
Linux 4.20 is running like a cat.
Comment by loqs (loqs) - Friday, 04 January 2019, 18:50 GMT Comment by Benoit Brummer (trougnouf) - Wednesday, 09 January 2019, 17:23 GMT
These fixes (amd_iommu=off, amd_iommu=soft, amd_iommu=off ivrs_ioapic[32]=00:14.0) all fail on my hp-envy-15-bq100-x360, even booting from the latest USB. There's a corrupted line on the bottom of the screen and it freezes. I deleted the previous kernel from the cache so my laptop is unusable at the moment.

edit: actually I can get it to work with linux-lts which is 4.19
Comment by raneon (raneon) - Wednesday, 09 January 2019, 19:39 GMT
@Benoit: did you try my workaround? Just deactivate modesetting with the boot parameter nomodeset. Then you can boot and install linux-lts.
Comment by Benoit Brummer (trougnouf) - Wednesday, 09 January 2019, 20:07 GMT
@raneon I just tried nomodeset with kernel 4.20 and it booted, thank you! :) I missed your comment somehow, I had already downloaded the 2018.11 iso and installed linux-lts from there.
Comment by loqs (loqs) - Thursday, 24 January 2019, 16:47 GMT Comment by loqs (loqs) - Monday, 18 February 2019, 22:01 GMT Comment by loqs (loqs) - Saturday, 23 February 2019, 23:52 GMT
Has the issue been resolved in 4.20.11+ ?
Comment by raneon (raneon) - Sunday, 07 April 2019, 13:46 GMT
I've tried it with Linux 5.0.6 and during modeset it still fails booting. I'm still stuck with Linux-lts.
Comment by loqs (loqs) - Thursday, 11 April 2019, 20:51 GMT
There is no dmesg or much else to go on beyond it started with linux 4.20 which is why I am having to guess at what upstream fix may resolve it.
Can you bisect between 4.19 and 4.20 to find the causal commit?
Have you reported the issue upstream?
Comment by raneon (raneon) - Saturday, 13 July 2019, 14:47 GMT
Linux 5.2 boots fine now for me. Tested with HP Envy x360 bq102ng and the latest F21 bios.

Loading...