Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#61249 - [lightdm-gtk-greeter] at-spi-bus-launcher and upstart never worked.

Attached to Project: Arch Linux
Opened by Eric Wang (enihcam) - Wednesday, 02 January 2019, 15:21 GMT
Last edited by Andreas Radke (AndyRTR) - Tuesday, 10 December 2019, 12:54 GMT
Task Type Bug Report
Category Packages: Extra
Status Assigned
Assigned To Maxime Gauduin (Alucryd)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 3
Private No

Details

Description:

Open /var/log/lightdm/seat0-greeter.log, and you shall see:
** (lightdm-gtk-greeter:1152): WARNING **: 22:58:05.096: [PIDs] Failed to execute command: /usr/lib/at-spi2-core/at-spi-bus-launcher
** (lightdm-gtk-greeter:1152): WARNING **: 22:58:05.097: [PIDs] Failed to execute command: upstart

This is because
1. The path of at-spi-bus-launcher is incorrect;
2. Archlinux does use upstart by default.

Since they never work, please use --disable-at-spi-command and --disable-indicator-services-command in build().

Additional info:
* package version(s)
* config and/or log files etc.


Steps to reproduce:
This task depends upon

Loading...