Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#61230 - [linux]Nouveau driver stop working with Linux 4.20

Attached to Project: Arch Linux
Opened by Obs (obspm) - Tuesday, 01 January 2019, 13:59 GMT
Last edited by freswa (frederik) - Sunday, 13 September 2020, 13:56 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To Jan Alexander Steffens (heftig)
Architecture x86_64
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No



After upgrade to linux 4.20 my Xorg session does not start, or to be more precise it's start bug almost no image on the screen. Just some random color.
I'm not sure if it's related to the or not.

What I'm sure is after downgrade to linux 4.19-12 everything work fine.

I'm not sure if the problem is with xf86-video-nouveau, I just notice no upgrade of xf86-video-nouveau after upgrade to 4.20

Additional info:
* package version(s)
xf86-video-nouveau : 1.0.15-3
* config and/or log files etc.

Steps to reproduce:

After upgrade the kernel, no X11 (launch by gdm)

This task depends upon

Closed by  freswa (frederik)
Sunday, 13 September 2020, 13:56 GMT
Reason for closing:  Not a bug
Additional comments about closing:  This is not a packaging bug. If still applicable, report upstream. Thank you
Comment by Obs (obspm) - Tuesday, 01 January 2019, 17:22 GMT
Forget to say the GPU is a old Nvidia Quadro 2000
Comment by loqs (loqs) - Tuesday, 01 January 2019, 20:28 GMT
Please post the Xorg.log from before and after the upgrade (as gdm is launching X it will be in the system journal)
Is modesetting also affected?
Comment by Vinux (vinux) - Tuesday, 01 January 2019, 21:26 GMT
Same problem for me.
Note that I was able to get Xorg session working by appending 'single' to grub kernel command line and then as root restoring default: systemctl default
Comment by Олег (Xpom8) - Wednesday, 02 January 2019, 09:09 GMT
With proprietary the same story? If not, then it is worth trying to install proprietary, it can help.
sudo pacman -Syy
sudo pacman -S nvidia
Comment by Obs (obspm) - Wednesday, 02 January 2019, 09:30 GMT
Well It's weirder than I imagine.

Yesterday after you request the Xorg.log, because I want to able to have a session, I disable gdm (systemctl disable gdm), I make the upgrade and reboot.

After the reboot I log in the console and launch a systemctl start gdm...and it's works. So I re-enable gdm and reboot, still working.

This morning I start the PC and...nothing work same problem as at the beginning, just some unstable weird colors on the screen (still on automatic launch gdm), I get the /var/log/Xorg.log.0 and disable the gdm at start and reboot. Launch gdm with systemctl's working....

Comment by Vinux (vinux) - Wednesday, 02 January 2019, 09:37 GMT
Here are the 2 logs.
Working use 'single' in kernel command line, and then I'm returning to normal mode using 'systemctl default': Display is then working nicely.
Failing use the default command line, and display is vertically misaligned.

Not so much difference in the logs from my point of view. Working goes a bit further in modeset step.

I will try the nvidia driver. Thanks for your support!
Comment by Vinux (vinux) - Wednesday, 02 January 2019, 11:26 GMT
Installing nvidia-340xx worked around the problem for me (Nvidia GT218).
Comment by Vinux (vinux) - Wednesday, 02 January 2019, 13:44 GMT
Comment by Paul Hentschel (hpmachining) - Friday, 04 January 2019, 22:11 GMT
I have this same issue in Arch linux with gdm service enabled. I get to the login screen, but after entering password system hangs. I can switch to TTY but it is very slow in responding. If I disable gdm and login to terminal and start gdm manually, gnome starts fine. Downgrading to linux 4.19.12 also fixes it. In case it matters, I am not using Wayland. I have attached a journalctl log from boot with gdm enabled and 4.20 kernel. I also attached the results of lspci -vnn and lsmod (after downgrading to 4.19.12). My processor is Intel(R) Core(TM) i5-8250U CPU @ 1.60GHz. Let me know if there is anything else I can provide.

Blacklisting nouveau or installing nvidia package works around the issue. I did not have to blacklist nouveau with kernel 4.19
Comment by Andreas Radke (AndyRTR) - Tuesday, 10 December 2019, 12:50 GMT
Is this still an issue?
Comment by Jörg Schray (schrayj) - Monday, 04 May 2020, 06:59 GMT
I had the same issue with a GeForce GT 220 when linux-lts switched to 5.4. - Starting up gnome produced:

nouveau 0000:01:00.0: gnome-shell[13877]: failed to idle channel 6 [gnome-shell[13877]] (see trying_to_vfree_bad_address.log for linux-lts-5.4.21 and trying_to_vfree_bad_address_5.4.32.log for linux-lts 5.4.32)


nouveau 0000:01:00.0: fifo: channel 6 [gnome-shell[13877]] unload timeout (see timeout.log for linux-lts-5.4.21 and timeout_5.4.32.log for linux-lts 5.4.32)

I don't recall exactly, if it was with the 5.4-lts kernel or with a non-lts version, where I also observed a messed-up screen with colored stripes after wakeup from suspend.

I tried the current linux kernels 5.5 or 5.6 also, but had the same issue.

My current solution is keeping the 4.19 kernel building my own package...

BTW: There is an open issue upstream