Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#61214 - [openssl] blake2b512 / sha3-512 invalid digest type

Attached to Project: Arch Linux
Opened by ipp (n8V8r) - Sunday, 30 December 2018, 17:16 GMT
Last edited by Eli Schwartz (eschwartz) - Sunday, 30 December 2018, 17:18 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To No-one
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: Since 1.1.1.a-1 provides support for blake2b512 it would be expected such to work when generating certificates which however does not.


Additional info:
* package version(s) 1.1.1.a-1
* config and/or log files etc.

OpenSSL> list -digest-commands
blake2b512 blake2s256 gost md4
md5 mdc2 rmd160 sha1
sha224 sha256 sha3-224 sha3-256
sha3-384 sha3-512 sha384 sha512
sha512-224 sha512-256 shake128 shake256
sm3

___

OpenSSL> list -digest-algorithms
...
BLAKE2b512
...
SHA3-512
...

___

Steps to reproduce:

in openssl_ca.conf set 'default_md = blake2b512' or 'default_md = sha3-512'

generating a certificate ends with

'error:100C508A:elliptic curve routines:pkey_ec_ctrl:invalid digest type:crypto/ec/ec_pmeth.c:327:'
This task depends upon

Closed by  Eli Schwartz (eschwartz)
Sunday, 30 December 2018, 17:18 GMT
Reason for closing:  Duplicate
Additional comments about closing:  FS#61213 don't do that

Loading...