Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#61207 - [gitlab] Needs rebuild for http-parser 2.9

Attached to Project: Community Packages
Opened by Caleb Maclennan (alerque) - Saturday, 29 December 2018, 10:37 GMT
Last edited by Sven-Hendrik Haase (Svenstaro) - Saturday, 29 December 2018, 16:27 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Sven-Hendrik Haase (Svenstaro)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

The included ruby rugged library is looking for http-parser so version 2.8, which no longer exists because the community repo has 2.9 now. This makes everything die, gitlab does not function as built in [community] right now.
This task depends upon

Closed by  Sven-Hendrik Haase (Svenstaro)
Saturday, 29 December 2018, 16:27 GMT
Reason for closing:  Fixed
Comment by Caleb Maclennan (alerque) - Saturday, 29 December 2018, 10:41 GMT
Almost exactly the same symptoms and cure as described in https://bugs.archlinux.org/task/57544, but for a different version. Confirmed downgrading to 2.8 makes things work again for the moment.
Comment by Giovanni Harting (IdleGandalf) - Saturday, 29 December 2018, 13:39 GMT
Can confirm, downgrading to http-parser-2.8.1-2 restores functionality.
Comment by Sven-Hendrik Haase (Svenstaro) - Saturday, 29 December 2018, 14:33 GMT
Test now.
Comment by Giovanni Harting (IdleGandalf) - Saturday, 29 December 2018, 14:40 GMT
Works with 11.6.0-3. Thanks!

Loading...