Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#61197 - [appstream-glib][flatpak] Plasmashell 5.12 freeze on right click

Attached to Project: Arch Linux
Opened by Stefano Coronado (stefnix) - Friday, 28 December 2018, 04:20 GMT
Last edited by Antonio Rojas (arojas) - Tuesday, 15 January 2019, 21:10 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Jan Alexander Steffens (heftig)
Bartłomiej Piotrowski (Barthalion)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 4
Private No

Details

Description:
Using KDE Plasma 5.12 on a recently installed Arch Linux. When right clicking in the Application Menu on a program, say to add it to favorites.
The panel and application menu freezes until I kill off the plasmashell process

I have bumblebee installed on my Nvidia Optimus laptop if that is important

Additional info:

* config and/or log files etc: Can't seem to start plasmashell from the debugger per my expertise, so I can't really give much of a stack trace


Steps to reproduce:

1. Switch out the default kickoff menu with the alternative application menu
2. Search for an application.
3. Right click and be forced to open Konsole to kill off the frozen plasmashell instance.
This task depends upon

Closed by  Antonio Rojas (arojas)
Tuesday, 15 January 2019, 21:10 GMT
Reason for closing:  Fixed
Additional comments about closing:  flatpak 1.1.3
Comment by Stefano Coronado (stefnix) - Friday, 28 December 2018, 04:26 GMT
I figured out why it wasn't running in gdb, I should have run plasmashell instead of passing it into kstart5.

Anyways, this is the output I have been getting when it freezes

(process:21943): GLib-GObject-WARNING **: 23:25:24.779: cannot register existing type 'AsLaunchable'

(process:21943): GLib-GObject-WARNING **: 23:25:24.779: cannot add private field to invalid (non-instantiatable) type '<invalid>'

(process:21943): GLib-CRITICAL **: 23:25:24.779: g_once_init_leave: assertion 'result != 0' failed

(process:21943): GLib-GObject-CRITICAL **: 23:25:24.779: g_object_new_with_properties: assertion 'G_TYPE_IS_OBJECT (object_type)' failed

Comment by Antonio Rojas (arojas) - Saturday, 05 January 2019, 09:32 GMT
Run "gdb plasmawindowed", then "(gdb) r org.kde.plasma.kickoff", hit ctrl+C when it freezes, and get a backtrace
Comment by Stefano Coronado (stefnix) - Saturday, 05 January 2019, 16:21 GMT
Hope this helps.
Comment by Antonio Rojas (arojas) - Saturday, 05 January 2019, 17:06 GMT
Does appstream work at all? Try eg. "appstreamcli search plasma"
Comment by Stefano Coronado (stefnix) - Saturday, 05 January 2019, 17:08 GMT
Yes, appstream works fine. The issue here may be flatpak

edit: wrong bug thread.
Comment by Antonio Rojas (arojas) - Saturday, 05 January 2019, 17:18 GMT
Please attach the contents of your /var/cache/app-info/
Comment by Stefano Coronado (stefnix) - Saturday, 05 January 2019, 17:27 GMT
found only one archive in this directory, and it's too big to attach
Comment by Antonio Rojas (arojas) - Saturday, 05 January 2019, 18:12 GMT
Then send it directly by email (arojas@archlinux.org)
Comment by Antonio Rojas (arojas) - Sunday, 13 January 2019, 17:31 GMT
This is caused by a symbol clash between appstream and appstream-glib. Related upstream reports:

https://github.com/flatpak/flatpak/issues/2549
https://github.com/hughsie/appstream-glib/pull/281
Comment by Antonio Rojas (arojas) - Monday, 14 January 2019, 17:21 GMT Comment by Bartłomiej Piotrowski (Barthalion) - Tuesday, 15 January 2019, 20:33 GMT
…which landed in [extra] in flatpak-1.1.3-1.
Comment by Stefano Coronado (stefnix) - Tuesday, 15 January 2019, 20:56 GMT
...which fixed this bug that has been plaguing Discover and plasmashell

Loading...