Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#61185 - [virtualbox-guest-utils] VBoxService fails to start

Attached to Project: Community Packages
Opened by nl6720 (nl6720) - Thursday, 27 December 2018, 08:51 GMT
Last edited by Christian Hesse (eworm) - Tuesday, 08 January 2019, 14:36 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Christian Hesse (eworm)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 11
Private No

Details

Description:
vboxservice.service fails to start and thus shared folder automounting doesn't work.

systemctl status vboxservice.service shows:
ExecStart=/usr/bin/VBoxService -f (code=exited, status=1/FAILURE)

journal shows an error:
main Error: Failed to become guest control master: VERR_VERSION_MISMATCH
main Error: Service 'control' failed to initialize: VERR_VERSION_MISMATCH

Additional info:
* package version(s)
* config and/or log files etc.
virtualbox-guest-utils 6.0.0-1

Steps to reproduce:
This task depends upon

Closed by  Christian Hesse (eworm)
Tuesday, 08 January 2019, 14:36 GMT
Reason for closing:  Fixed
Additional comments about closing:  virtualbox 6.0.0-2
Comment by Evan McLean (ecognito) - Monday, 31 December 2018, 00:02 GMT
Having just updated guest and host to vbox 6.0.0, I am now seeing the same behaviour. Looking at my log, it looks the same as the one previously attached (sans dates).
Comment by Mario Jaeger (j00n) - Tuesday, 01 January 2019, 17:12 GMT
Hi,
Yes, I'm having the same issue. No time synchronization, no automounts, no video auto adjustments since 6.0.0 in my ArchLinux Guest system (kernel 4.20.0-arch1-1-ARCH). Also, can we change the "Category" to "Packages" rather than "Testing"? It is not in testing anymore. I would also change the priority here.
Comment by Luís Mendes (luisgbm) - Wednesday, 02 January 2019, 13:24 GMT
I'm having the same problem, with the very same output log.
Comment by philanecros (philanecros) - Friday, 04 January 2019, 02:12 GMT
Same problem here. With same log entries.
Comment by Pedro Batista (pedosb) - Friday, 04 January 2019, 11:18 GMT
Same here.
Comment by nvb (nvb) - Monday, 07 January 2019, 08:32 GMT
Same here too.
Host is a pure arch linux (virtual box version 6.0.0 r127442), Virtual Box client is an antergos (virtual box version 6.0.0 r127442).

```
Error: Failed to become guest control master: VERR_VERSION_MISS...
Error: Service 'control' failed to initialize: VERR_VERSION_MI...
```
Comment by Christian Hesse (eworm) - Tuesday, 08 January 2019, 13:20 GMT
Please try virtualbox 6.0.0-2.
Comment by Mario Jaeger (j00n) - Tuesday, 08 January 2019, 13:59 GMT
I can confirm the fix. 'VBoxService -f' is started and everything works now as expected. Thanks a lot!
Comment by nl6720 (nl6720) - Tuesday, 08 January 2019, 14:16 GMT
with virtualbox-guest-utils 6.0.0-2, VBoxService starts but automounting doesn't work.

automount Error: vbsvcAutomounterMountIt: Failed to mount 'VM-shared' on '/media/sf_VM-shared' because it is probably mounted elsewhere arleady! (-1,22)
automount Error: vbsvcAutomounterMountIt: Failed to mount 'VM-shared' on '/media/sf_VM-shared' because it is probably mounted elsewhere arleady! (-1,22)

It's not mounted elsewhere.
Comment by Christian Hesse (eworm) - Tuesday, 08 January 2019, 14:36 GMT
The automount thing is a different issue. Look for existing issue or open new one.

Loading...