Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#61151 - [elfutils][binutils] version 0.175 causes objdump errors

Attached to Project: Arch Linux
Opened by Gerhard Bogner (slashME) - Friday, 21 December 2018, 19:08 GMT
Last edited by Anatol Pomozov (anatolik) - Friday, 15 February 2019, 14:44 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Laurent Carlier (lordheavy)
Anatol Pomozov (anatolik)
Bartłomiej Piotrowski (Barthalion)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Compiling custom dvb kernel modules with elfutils-0.175 leads to following errors (for every object file):

objdump: /usr/src/linux-dvb-drivers/media_build/v4l/.tmp_mantis_pcmcia.o: unable to initialize decompress status for section .debug_info
objdump: /usr/src/linux-dvb-drivers/media_build/v4l/.tmp_mantis_pcmcia.o: unable to initialize decompress status for section .debug_info
objdump: /usr/src/linux-dvb-drivers/media_build/v4l/.tmp_mantis_pcmcia.o: file format not recognized

Downgrading to elfutils-0.174 (and the corresponding libelf) fixes this problem.
This task depends upon

Closed by  Anatol Pomozov (anatolik)
Friday, 15 February 2019, 14:44 GMT
Reason for closing:  Fixed
Comment by loqs (loqs) - Friday, 21 December 2018, 20:39 GMT Comment by Laurent Carlier (lordheavy) - Monday, 24 December 2018, 04:43 GMT
Orginal bug report https://sourceware.org/bugzilla/show_bug.cgi?id=23916

It's a binutils bug
Comment by Anatol Pomozov (anatolik) - Monday, 24 December 2018, 21:10 GMT Comment by Anatol Pomozov (anatolik) - Wednesday, 26 December 2018, 15:08 GMT
Could you please provide reproducing steps for this issue?
Comment by Anatol Pomozov (anatolik) - Wednesday, 26 December 2018, 16:06 GMT
Binutils version binutils-2.31.1-4 with upstream patches been pushed to [testing]. Please verify that it fixes your issue and works with other your use-cases. Thanks for the feedback in advance.
Comment by Gerhard Bogner (slashME) - Wednesday, 26 December 2018, 17:39 GMT
I had this problem while compiling kernel modules the normal way -- just make oldconfig && make -j$(nproc).

The binutils update from testing does fix it, I'll try recompiling some other aur packages next.
Comment by Gerhard Bogner (slashME) - Wednesday, 26 December 2018, 18:03 GMT
I had no problems recompiling a few other packages, and had no issues running them (or the kernel modules) so far.
Comment by Anatol Pomozov (anatolik) - Wednesday, 26 December 2018, 18:07 GMT
Sounds great. I'll keep binutils in testing for a while. If anyone finds any issues with this patched version please let me know.

Loading...