Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#61140 - [spice]virt-manager spice auth fails after upgrade: "authentication failed: wrong password?"

Attached to Project: Arch Linux
Opened by Niccolò Belli (darkbasic) - Thursday, 20 December 2018, 13:37 GMT
Last edited by Sven-Hendrik Haase (Svenstaro) - Sunday, 04 July 2021, 21:14 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Sven-Hendrik Haase (Svenstaro)
Anatol Pomozov (anatolik)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

I don't know which package caused this regression, but this is the list of packages I updated with last upgrade:

archlinux-keyring-20181218-1-any
e2fsprogs-1.44.5-1-x86_64
libsystemd-239.370-1-x86_64
ca-certificates-mozilla-3.41-1-x86_64
libnghttp2-1.35.1-1-x86_64
curl-7.63.0-1-x86_64
dbus-1.12.12-1-x86_64
device-mapper-2.02.183-1-x86_64
glib2-2.58.2-1-x86_64
libassuan-2.5.2-1-x86_64
gnupg-2.2.12-1-x86_64
libelf-0.175-1-x86_64
systemd-239.370-1-x86_64
linux-firmware-20181218.0f22c85-1-any
linux-4.19.10.arch1-1-x86_64
linux-headers-4.19.10.arch1-1-x86_64
logrotate-3.15.0-1-x86_64
lvm2-2.02.183-1-x86_64
nss-3.41-1-x86_64
systemd-sysvcompat-239.370-1-x86_64
bind-tools-9.13.5-1-x86_64
git-2.20.1-1-x86_64
librsvg-2:2.44.10-1-x86_64
gtk-update-icon-cache-3.24.2+7+g43aeb52b73-1-x86_64
llvm-libs-7.0.1-1-x86_64
mesa-18.3.1-1-x86_64
polkit-0.115+24+g5230646-1-x86_64
gtk3-3.24.2+7+g43aeb52b73-1-x86_64
libatomic_ops-7.6.8-1-x86_64
mtools-4.0.23-1-x86_64
python-six-1.12.0-1-any
python-setuptools-1:40.6.3-1-any
vte-common-0.54.3-1-x86_64
vte3-0.54.3-1-x86_64
qemu-3.1.0-1-x86_64
wget-1.20-1-x86_64
go-2:1.11.3-1-x86_64
oniguruma-6.9.1-1-x86_64
python-sqlalchemy-1.2.15-1-x86_64

Each time I try to connect to the spice server using virt-manager I get the following error: "authentication failed: wrong password?"

I tried to change the password and even copy-paste it but nothing helps. It works flawlessly if I don't set the password.
Unfortunately this server is in production so I need to get it working as soon as possible.
This task depends upon

Closed by  Sven-Hendrik Haase (Svenstaro)
Sunday, 04 July 2021, 21:14 GMT
Reason for closing:  Works for me
Comment by Andreas Radke (AndyRTR) - Tuesday, 10 December 2019, 12:40 GMT
Is this still an issue?
Comment by Sven-Hendrik Haase (Svenstaro) - Sunday, 04 July 2021, 21:14 GMT
I'm running this and it's definitely not an issue anymore currently. Also, the reporter didn't come back to this in more than a year. Let's consider it closed.

Loading...