Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#61115 - [xterm] crashes with mutt

Attached to Project: Arch Linux
Opened by Gaetan Bisson (vesath) - Monday, 17 December 2018, 22:22 GMT
Last edited by Gaetan Bisson (vesath) - Wednesday, 19 December 2018, 05:16 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Andreas Radke (AndyRTR)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Running mutt on a certain mailbox inside xterm I get:

xterm: warning, error event received:
X Error of failed request: BadLength (poly request too large or internal Xlib length error)
Major opcode of failed request: 139 (RENDER)
Minor opcode of failed request: 20 (RenderAddGlyphs)
Serial number of failed request: 3647
Current serial number in output stream: 3695

The return code is 83.

Narrowing down the exact cause of the crash is not straightforward but I'll try to bisect my mailbox's content to see what exactly is the problem. I can reproduce this bug with both xterm-337-1 from [extra] and xterm-339-1 from [testing].
This task depends upon

Closed by  Gaetan Bisson (vesath)
Wednesday, 19 December 2018, 05:16 GMT
Reason for closing:  Fixed
Additional comments about closing:  xterm-340-1 in [testing]
Comment by Gaetan Bisson (vesath) - Monday, 17 December 2018, 22:27 GMT
If I remove `*faceName: Mono` from xrdb (and then xterm defaults to using the fixed bitmap font) the issue goes away.
(Whether `Mono` resolves to Inconsolata, Nimbus or Menlo does not change anything.)
Comment by Gaetan Bisson (vesath) - Monday, 17 December 2018, 22:39 GMT
I've identified the exact glyph causing this issue: it's `🛄` (baggage claim emoji). Pasting it into `xterm` with a scaled font makes it crash.
Comment by Gaetan Bisson (vesath) - Tuesday, 18 December 2018, 00:30 GMT
I have confirmed that xterm-335-1 was not affected so the bug appeared in xterm-337-1. Cheers.
Comment by Andreas Radke (AndyRTR) - Tuesday, 18 December 2018, 17:45 GMT
Please try version 340 in testing - maybe a duplicate of  FS#58706  - if not please get in contact with upstream.
Comment by Gaetan Bisson (vesath) - Wednesday, 19 December 2018, 05:16 GMT
Great! Version 340 works just fine. Cheers!

Loading...