Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#6111 - Tool 'km' offers unloadable console fonts to choose from

Attached to Project: Arch Linux
Opened by Dennis Herbrich (gyroplast) - Saturday, 30 December 2006, 22:51 GMT
Task Type Bug Report
Category Installation
Status Closed
Assigned To Judd Vinet (judd)
Architecture not specified
Severity High
Priority Low
Reported Version 0.7.2 Gimmick
Due in Version 0.8 Voodoo
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

The handy little tool '/bin/km' as supplied on the 0.8 Alpha isos,
used to choose keymap and a console font with a GUI, uses a method
to scan for fonts that is unsuitable in it's current state.
Line 37 of the script contains the following code:

for i in `find $BASEDIR/consolefonts -follow -name "*.gz" | sed '|^.*/||g' | sort`; do

Besides of -follow being marked as deprecated in favor of -L, the
`find` command used here also searches subdirectories of the "consolefonts"
directory. Unfortunately, there's a directory called "partialfonts" below
that is also searched because of this, containing a variety of fonts
that appear later in the menu, but are not properly loaded since the call to
setfont looks like this in lines 54 and 56:

setfont $BASEDIR/consolefonts/$font [...]

To reproduce this error, just run 'km', skip the keymap chooser, and then
choose one of the presented fonts prefixed with '8859-1' and the like, which
are contained in the partialfonts subdir.

Fix considerations:
It's probably enough to just add '-maxdepth 1' to the find command line to prevent
checking the subdirectories and presenting choices that aren't sensible anyway.
I do not know, however, what purpose these partialfonts are supposed to have exactly,
so just leaving them out might not be advisable.

--

Please see the other task for another bug regarding .cp.gz files.
This task depends upon

This task blocks these from closing
 FS#6031 - 0.8 installation ISO showstoppers 
Closed by  Tobias Powalowski (tpowa)
Sunday, 31 December 2006, 11:50 GMT
Reason for closing:  Fixed

Loading...