Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#61108 - makepkg doesn't honor 'upx' in the option array

Attached to Project: Arch Linux
Opened by tom (brikler) - Monday, 17 December 2018, 08:58 GMT
Last edited by Eli Schwartz (eschwartz) - Monday, 17 December 2018, 09:01 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To No-one
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

salve

i set 'upx' in the option array but the binary will be not compressed.
i tried it with two PKGBUILDS with the same result a uncompressed binary.

i am using the UPX PKGBUILD as example https://projects.archlinux.de/svntogit/community.git/tree/trunk/PKGBUILD?h=packages/upx
==> Tidying install...
-> Removing libtool files...
-> Purging unwanted files...
-> Removing static library files...
-> Stripping unneeded symbols from binaries and libraries...
-> Compressing binaries with UPX... #it shows the message but it doesn't the job
-> Compressing man and info pages...
==> Checking for packaging issue...
==> Creating package "upx"...
-> Generating .PKGINFO file...
-> Generating .BUILDINFO file...
-> Generating .MTREE file...
-> Compressing package...
This task depends upon

Closed by  Eli Schwartz (eschwartz)
Monday, 17 December 2018, 09:01 GMT
Reason for closing:  Not a bug
Additional comments about closing:  makepkg no longer provides any upx option, ask whoever you got your makepkg extension from.

Loading...