Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#61092 - [mariadb] Enable OQGRAPH storage engine support

Attached to Project: Arch Linux
Opened by Brian R (brep) - Saturday, 15 December 2018, 20:06 GMT
Last edited by Toolybird (Toolybird) - Friday, 22 July 2022, 23:59 GMT
Task Type Feature Request
Category Packages: Extra
Status Closed
Assigned To Christian Hesse (eworm)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 4
Private No

Details

Description: Please include the Open Query GRAPH computation engine, or OQGRAPH as the engine itself is called, as part of the main MariaDB package. OQGRAPH allows MariaDB to handle hierarchies (tree structures) and complex graphs (nodes having many connections in several directions). This addition makes MariaDB one of the most compelling database management systems available today.

MariaDB officially includes OQGRAPH with the current stable release (e.g., mariadb-10.3.11-linux-systemd-x86_64.tar.gz for systems with systemd, found at https://downloads.mariadb.org/interstitial/mariadb-10.3.11/bintar-linux-systemd-x86_64/mariadb-10.3.11-linux-systemd-x86_64.tar.gz/from/http%3A//mirror.jaleco.com/mariadb/). It is also part of MariaDB in many other Linux distros. However, the Arch Linux package does not include it.

It requires shared library /usr/lib/mysql/plugin/ha_oqgraph.so (part of the MariaDB source) and libJudy.so.1 (not currently available in the Arch repositories). libJudy is a C library for creating and accessing dynamic arrays. As far as I know, those are the only two files required for OQGRAPH to be functional in MariaDB on Arch.

General information here: https://mariadb.com/kb/en/library/oqgraph-storage-engine/

OQGRAPH is available for many versions of MariaDB, including the version currently in the Arch repos.

"You can grab MariaDB 5.2 or higher at mariadb.org, and you can find the source in the oqgraph storage engine plugin directory of the mariadb tree on Launchpad. The oqgraph project on Launchpad tracks the historical implementation for MySQL 5.0, and was used for the newer persistent v3 (in MariaDB 10.0 and above)."

It would be nice to have at least MariaDB version 10.3.3 on Arch. Arch is currently on mariadb 10.1.37-1. The latest stable release is 10.3.11 at this time. See https://downloads.mariadb.org/mariadb/+releases/

See https://openquery.com.au/products/graph-engine for background.

This task depends upon

Closed by  Toolybird (Toolybird)
Friday, 22 July 2022, 23:59 GMT
Reason for closing:  Implemented
Additional comments about closing:  @josiah47 - Seems to be working fine on 10.8.3 even in manjaro. Thanks!
Comment by loqs (loqs) - Saturday, 15 December 2018, 20:20 GMT
It would be nice to have at least MariaDB version 10.3.3 on Arch.
https://bbs.archlinux.org/viewtopic.php?id=240012 / https://github.com/perl5-dbi/DBD-mysql/issues/275
Comment by Josh (josiah47) - Wednesday, 08 December 2021, 13:24 GMT
This would be really nice to have now. looks like judy is now in the official repos...
Comment by Christian Hesse (eworm) - Monday, 20 December 2021, 19:58 GMT
Please test mariadb 10.6.5-2...

Loading...