Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#61069 - [graphviz] wrong file persmissions for configuration file

Attached to Project: Arch Linux
Opened by John (irrlicht) - Friday, 14 December 2018, 03:29 GMT
Last edited by David Runge (dvzrv) - Sunday, 08 September 2019, 21:51 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

The actual version of graphviz has wrong file permissions for file:

ls -lah /usr/lib/graphviz/config6
-rw------- 1 root root 3.5K Dec 14 04:10 /usr/lib/graphviz/config6

File is only readable for root, therefore executing the following command is not possible:

$dot -c
Error: failed to open /usr/lib/graphviz/config6 for read.
There is no layout engine support for "dot"
Perhaps "dot -c" needs to be run (with installer's privileges) to register the plugins?

Additional info:
* package version is 2.40.1-14


Steps to reproduce:

1) install graphviz
2) try to call dot command with user privileges.


This task depends upon

Closed by  David Runge (dvzrv)
Sunday, 08 September 2019, 21:51 GMT
Reason for closing:  Not a bug
Comment by Jake Kreiger (Magali75) - Friday, 14 December 2018, 13:20 GMT
On my system that file has correct permissions:

/usr/bin/ls -lah /usr/lib/graphviz/config6
-rw-r--r-- 1 root root 3.5K Nov 29 10:06 /usr/lib/graphviz/config6

dot -c still fails because the file isn't writable, which is expected:

dot -c
Error: failed to open /usr/lib/graphviz/config6 for write.

Comment by Anton Leontiev (bunder) - Saturday, 23 February 2019, 08:11 GMT
On my system this file is also readable by all, but writable only by root (644). This is right permissions for file in /usr/lib. If you want to regenerate system-wide configuration file, you should do this as root. IMHO, this issue should be closed as Won't do/Work as expected.
Comment by David Runge (dvzrv) - Sunday, 08 September 2019, 21:50 GMT
@irrlicht: Thanks for the report, but I guess a reinstallation of graphviz (or an upgrade) will fix this problem for you.

Loading...