Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#61067 - [wpa_supplicant] Version 2.7 is still built against OpenSSL 1.0

Attached to Project: Arch Linux
Opened by Daniel Kamil Kozar (XAVeRY) - Thursday, 13 December 2018, 22:24 GMT
Last edited by Eli Schwartz (eschwartz) - Thursday, 13 December 2018, 22:27 GMT
Task Type General Gripe
Category Packages: Testing
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Version 2.7 of wpa_supplicant has been modified to support OpenSSL 1.1.1, as the changelog at http://w1.fi/cgit/hostap/plain/wpa_supplicant/ChangeLog says.
However, the PKGBUILD still requires openssl-1.0 and uses custom CFLAGS and LDFLAGS (actually, LIBS) to ensure that the package is built against the 1.0 version of OpenSSL. I've built the supplicant with the newest OpenSSL and have been running it for a few days now without any issues.
This may be a good time to switch to 1.1.1 in the PKGBUILD as well, especially since it was the last package on my system that depended on OpenSSL 1.0.
This task depends upon

Closed by  Eli Schwartz (eschwartz)
Thursday, 13 December 2018, 22:27 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#54390   FS#59171   FS#60386   FS#60984   FS#60987   FS#61013 

Loading...