Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#61062 - [libgda] core dump

Attached to Project: Arch Linux
Opened by Ghorban M. Tavakoly (gurban) - Thursday, 13 December 2018, 15:19 GMT
Last edited by Andreas Radke (AndyRTR) - Tuesday, 10 December 2019, 12:27 GMT
Task Type Bug Report
Category Packages: Extra
Status Assigned
Assigned To Jan Alexander Steffens (heftig)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 0
Private No

Details

Description:
For a few months, I can't run libgda programs in arch linux. All
supplied utilities like libgda-browser-5.0, gdaui-demo-5.0, etc
failed with core dump. So I decided to report the bug.

I've also attached gdb trace log file.

Core system:
------------
* core/linux 4.19.8.arch1-1
* core/glibc 2.28-5

Installed Version:
------------------
* extra/libgda 5.2.4+39+g3f70d4fce-2

Installed providers:
--------------------
* extra/libgda-firebird 5.2.4+39+g3f70d4fce-2
* extra/libgda-jdbc 5.2.4+39+g3f70d4fce-2
* extra/libgda-mysql 5.2.4+39+g3f70d4fce-2
* extra/libgda-postgres 5.2.4+39+g3f70d4fce-2

My system
---------
[gmt@x1 ~]$ uname -a
Linux x1 4.19.4-arch1-1-ARCH #1 SMP PREEMPT Fri Nov 23 09:06:58 UTC 2018 x86_64 GNU/Linux
[gmt@x1 ~]$ /usr/lib/libc.so.6
GNU C Library (GNU libc) stable release version 2.28.
...
Compiled by GNU CC version 8.2.1 20180831.
libc ABIs: UNIQUE IFUNC ABSOLUTE
...
[gmt@x1 ~]$ which gda-browser-5.0
/usr/bin/gda-browser-5.0

Steps to reproduce:
-------------------
[gmt@x1 ~]$ gda-browser-5.0

(gda-browser-5.0:11152): Gtk-WARNING **: 18:43:39.006: Theme parsing error: <data>:11:31: The style property GtkButton:default-border is deprecated and shouldn't be used anymore. It will be removed in a future version

(gda-browser-5.0:11152): Gtk-WARNING **: 18:43:39.006: Theme parsing error: <data>:12:39: The style property GtkButton:default-outside-border is deprecated and shouldn't be used anymore. It will be removed in a future version

(gda-browser-5.0:11152): Gtk-WARNING **: 18:43:39.006: Theme parsing error: <data>:13:29: The style property GtkButton:inner-border is deprecated and shouldn't be used anymore. It will be removed in a future version

(gda-browser-5.0:11152): Gtk-WARNING **: 18:43:39.006: Theme parsing error: <data>:32:31: The style property GtkButton:default-border is deprecated and shouldn't be used anymore. It will be removed in a future version

(gda-browser-5.0:11152): Gtk-WARNING **: 18:43:39.006: Theme parsing error: <data>:33:39: The style property GtkButton:default-outside-border is deprecated and shouldn't be used anymore. It will be removed in a future version

(gda-browser-5.0:11152): Gtk-WARNING **: 18:43:39.006: Theme parsing error: <data>:34:29: The style property GtkButton:inner-border is deprecated and shouldn't be used anymore. It will be removed in a future version
free(): invalid pointer
Aborted (core dumped)
This task depends upon

Comment by Ghorban M. Tavakoly (gurban) - Thursday, 13 December 2018, 15:23 GMT
I think there is a bug in libgda-firebird or libfbclient. I've removed
libgda-firebird provider and all programs work normally.

Should I report a bug against libgda-firebird?
Comment by Andreas Radke (AndyRTR) - Tuesday, 10 December 2019, 12:26 GMT
Is this still an issue?

Loading...