Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#61061 - [seahorse-nautilus] Missing *.ui files

Attached to Project: Arch Linux
Opened by helle vaanzinn (glitsj16) - Thursday, 13 December 2018, 14:12 GMT
Last edited by Jan Alexander Steffens (heftig) - Sunday, 09 February 2020, 19:10 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Jan Alexander Steffens (heftig)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:

The package is missing some ui files, which causes breakage in the --import option.

Additional info:
$ pacman -Q seahorse-nautilus
seahorse-nautilus 3.11.92+57+g390364d-1

Steps to reproduce:
$ seahorse-tool --import keys-file

(seahorse-tool:379): seahorse-nautilus-WARNING **: 13:04:38.173: couldn't load ui file: Failed to open file “/usr/share/seahorse-nautilus/uiseahorse-progress.ui”: No such file or directory

(seahorse-tool:379): seahorse-nautilus-WARNING **: 13:04:38.173: could not find widget progress for seahorse-progress.ui

(seahorse-tool:379): Gtk-CRITICAL **: 13:04:38.173: gtk_window_set_icon_name: assertion 'GTK_IS_WINDOW (window)' failed

(seahorse-tool:379): seahorse-nautilus-WARNING **: 13:04:38.173: could not find widget progress for seahorse-progress.ui

(seahorse-tool:379): seahorse-nautilus-CRITICAL **: 13:04:38.174: seahorse_widget_get_toplevel: assertion 'widget != NULL' failed

(seahorse-tool:379): seahorse-nautilus-WARNING **: 13:04:38.174: could not find widget progress for seahorse-progress.ui

(seahorse-tool:379): Gtk-CRITICAL **: 13:04:38.174: gtk_window_move: assertion 'GTK_IS_WINDOW (window)' failed

(seahorse-tool:379): seahorse-nautilus-WARNING **: 13:04:38.174: could not find widget progress for seahorse-progress.ui

(seahorse-tool:379): seahorse-nautilus-CRITICAL **: 13:04:38.174: progress_show: assertion 'w != NULL' failed

NOTE: although the output references 'uiseahorse-progress.ui' the upstream repo has 3 files in its tool dir that seem lost on Arch Linux:
- seahorse-multi-encrypt.ui
- seahorse-notify.ui
-seahorse-progress.ui

Regards
This task depends upon

Closed by  Jan Alexander Steffens (heftig)
Sunday, 09 February 2020, 19:10 GMT
Reason for closing:  Fixed
Additional comments about closing:  seahorse-nautilus 3.11.92+66
Comment by Eli Schwartz (eschwartz) - Thursday, 13 December 2018, 17:37 GMT
That file is not expected to exist, it should be compiled into the binary.

And I cannot duplicate your error.
Comment by helle vaanzinn (glitsj16) - Thursday, 13 December 2018, 20:46 GMT
Thanks for the response. Can't explain what's going on. The machine I was seeing this on is fully updated. I reinstalled a few times and now these error messages are gone. I get D-Bus errors now instead. As I'm using thunar instead of nautilus I decided to drop the package and wrote a simple shell script using gpg to import a keys file from a custom action. At least that works reliably. Again, thanks for clearing things up.
Comment by Balló György (City-busz) - Thursday, 13 December 2018, 21:19 GMT
I confirm this problem.

It was a bug in the meson port:
https://gitlab.gnome.org/GNOME/seahorse-nautilus/commit/0d7367ce837453189a8cb2704367736a536f27ce

The attached patch fixes the problem. I forwarded it to upstream:
https://gitlab.gnome.org/GNOME/seahorse-nautilus/merge_requests/1
Comment by helle vaanzinn (glitsj16) - Thursday, 13 December 2018, 21:46 GMT
Confirming the patch fixes things for me here. Thanks City-busz! Odd that eschwartz couldn't reproduce, perhaps it depends on the file used to import? Nice to see this is fixed nonetheless.

Loading...