Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#61002 - [opensmtpd] move from openssl-1.0 to openssl 1.1

Attached to Project: Community Packages
Opened by ua4000 (ua4000) - Saturday, 08 December 2018, 19:13 GMT
Last edited by Bruno Pagani (ArchangeGabriel) - Tuesday, 07 April 2020, 18:19 GMT
Task Type Feature Request
Category Packages
Status Closed
Assigned To Lukas Fleischer (lfleischer)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

At the moment opensmtpd relies on old openssl 1.0 arch package.

If it's possible: please migrate from openssl 1.0 to openssl 1.1.

Thanks very much!
This task depends upon

Closed by  Bruno Pagani (ArchangeGabriel)
Tuesday, 07 April 2020, 18:19 GMT
Reason for closing:  Implemented
Additional comments about closing:  Switched to libressl long ago, no issue has been reported since.
Comment by loqs (loqs) - Saturday, 08 December 2018, 20:35 GMT Comment by Bruno Pagani (ArchangeGabriel) - Friday, 12 April 2019, 13:03 GMT
That is not possible. What we need is libressl co-installable with openssl (i.e. namespaced). I think anthraxx (Levente Polyak) is the one working on this.
Comment by Maarten de Vries (de-vri-es) - Friday, 17 May 2019, 12:46 GMT
I've got some working packages in the AUR for LibreSSL side-by-side with OpenSSL, and OpenSMTPD 6.4.1p2:

https://aur.archlinux.org/packages/libressl-side
https://aur.archlinux.org/packages/opensmtpd-libressl

Currently running it on a backup relay, seems to be running smooth. I was still planning to let it run for a while before updating my main mail server though.

My main motivation wasn't getting rid of openssl-1.0, but upgrading to OpenSMTPD 6.4.1p2.
Comment by Bruno Pagani (ArchangeGabriel) - Sunday, 06 October 2019, 23:23 GMT
I’ve got LibreSSL in the repo now ([community-testing] for now), I’ve also made a build of opensmtpd 6.4.2p1 against it, but I need to check it works and add some message about configuration changes before pushing. Should be up this week if everything goes well.
Comment by Bruno Pagani (ArchangeGabriel) - Sunday, 20 October 2019, 19:11 GMT
So my system has been running the new version of OpenSMTPD without issue for a bit now, I’ve pushed the package to [testing].

Please let me know if it works OK for you, in which case I’ll move it to [community].

Loading...