Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#60993 - [unbound] "systemctl start unbound" fails

Attached to Project: Community Packages
Opened by Bjoern Franke (bjo) - Friday, 07 December 2018, 11:58 GMT
Last edited by Doug Newgard (Scimmia) - Sunday, 09 December 2018, 16:41 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
The systemd-service for unbound fails to start. Running unbound manually or via "unbound-control start" works fine. Maybe it would be better to use unbound-control for starting/stopping the service?

Additional info:
Dec 07 12:55:22 host systemd[1]: Started Unbound DNS Resolver.
Dec 07 12:55:22 host unbound[16274]: [16274:0] notice: init module 0: subnet
Dec 07 12:55:22 host unbound[16274]: [16274:0] notice: init module 1: validator
Dec 07 12:55:22 host unbound[16274]: [16274:0] notice: init module 2: iterator
Dec 07 12:55:22 host unbound[16274]: [16274:0] info: start of service (unbound 1.8.2).
Dec 07 12:55:22 host unbound[16274]: [16274:0] info: service stopped (unbound 1.8.2).
Dec 07 12:55:22 host unbound[16274]: [16274:0] info: server stats for thread 0: 0 queries, 0 answers from cache, 0 recursions, 0 prefetch, 0 rejected by ip ratelimiting
Dec 07 12:55:22 host unbound[16274]: [16274:0] info: server stats for thread 0: requestlist max 0 avg 0 exceeded 0 jostled 0
Dec 07 12:55:22 host unbound[16274]: [16274:0] info: server stats for thread 1: 0 queries, 0 answers from cache, 0 recursions, 0 prefetch, 0 rejected by ip ratelimiting
Dec 07 12:55:22 host unbound[16274]: [16274:0] info: server stats for thread 1: requestlist max 0 avg 0 exceeded 0 jostled 0
Dec 07 12:55:22 host systemd[1]: unbound.service: Service RestartSec=100ms expired, scheduling restart.
Dec 07 12:55:22 host systemd[1]: unbound.service: Scheduled restart job, restart counter is at 3.
Dec 07 12:55:22 host systemd[1]: Stopped Unbound DNS Resolver.
Dec 07 12:55:22 host systemd[1]: Started Unbound DNS Resolver.
Dec 07 12:55:22 host unbound[16285]: [16285:0] notice: init module 0: subnet
Dec 07 12:55:22 host unbound[16285]: [16285:0] notice: init module 1: validator
Dec 07 12:55:22 host unbound[16285]: [16285:0] notice: init module 2: iterator
Dec 07 12:55:23 host unbound[16285]: [16285:0] info: start of service (unbound 1.8.2).
Dec 07 12:55:23 host unbound[16285]: [16285:0] info: service stopped (unbound 1.8.2).
Dec 07 12:55:23 host unbound[16285]: [16285:0] info: server stats for thread 0: 0 queries, 0 answers from cache, 0 recursions, 0 prefetch, 0 rejected by ip ratelimiting
Dec 07 12:55:23 host unbound[16285]: [16285:0] info: server stats for thread 0: requestlist max 0 avg 0 exceeded 0 jostled 0
Dec 07 12:55:23 host unbound[16285]: [16285:0] info: server stats for thread 1: 0 queries, 0 answers from cache, 0 recursions, 0 prefetch, 0 rejected by ip ratelimiting
Dec 07 12:55:23 host unbound[16285]: [16285:0] info: server stats for thread 1: requestlist max 0 avg 0 exceeded 0 jostled 0
Dec 07 12:55:23 host systemd[1]: unbound.service: Service RestartSec=100ms expired, scheduling restart.
Dec 07 12:55:23 host systemd[1]: unbound.service: Scheduled restart job, restart counter is at 4.
Dec 07 12:55:23 host systemd[1]: Stopped Unbound DNS Resolver.
Dec 07 12:55:23 host systemd[1]: Started Unbound DNS Resolver.
Dec 07 12:55:23 host unbound[16288]: [16288:0] notice: init module 0: subnet
Dec 07 12:55:23 host unbound[16288]: [16288:0] notice: init module 1: validator
Dec 07 12:55:23 host unbound[16288]: [16288:0] notice: init module 2: iterator
Dec 07 12:55:23 host unbound[16288]: [16288:0] info: start of service (unbound 1.8.2).
Dec 07 12:55:23 host unbound[16288]: [16288:0] info: service stopped (unbound 1.8.2).
Dec 07 12:55:23 host unbound[16288]: [16288:0] info: server stats for thread 0: 0 queries, 0 answers from cache, 0 recursions, 0 prefetch, 0 rejected by ip ratelimiting
Dec 07 12:55:23 host unbound[16288]: [16288:0] info: server stats for thread 0: requestlist max 0 avg 0 exceeded 0 jostled 0
Dec 07 12:55:23 host unbound[16288]: [16288:0] info: server stats for thread 1: 0 queries, 0 answers from cache, 0 recursions, 0 prefetch, 0 rejected by ip ratelimiting
Dec 07 12:55:23 host unbound[16288]: [16288:0] info: server stats for thread 1: requestlist max 0 avg 0 exceeded 0 jostled 0
Dec 07 12:55:23 host systemd[1]: unbound.service: Service RestartSec=100ms expired, scheduling restart.
Dec 07 12:55:23 host systemd[1]: unbound.service: Scheduled restart job, restart counter is at 5.
Dec 07 12:55:23 host systemd[1]: Stopped Unbound DNS Resolver.
Dec 07 12:55:23 host systemd[1]: unbound.service: Start request repeated too quickly.
Dec 07 12:55:23 host systemd[1]: unbound.service: Failed with result 'start-limit-hit'.
Dec 07 12:55:23 host systemd[1]: Failed to start Unbound DNS Resolver.
lines 372-419/419 (END)



Steps to reproduce:
systemctl start unbound
This task depends upon

Closed by  Doug Newgard (Scimmia)
Sunday, 09 December 2018, 16:41 GMT
Reason for closing:  Not a bug
Comment by Bjoern Franke (bjo) - Sunday, 09 December 2018, 01:23 GMT
"ExecStart=/usr/bin/unbound -d" should fix the issue.
Comment by Jake Kreiger (Magali75) - Sunday, 09 December 2018, 10:08 GMT
No, taking care of pacnew files should fix the issue. This was discussed many time already:
https://bugs.archlinux.org/task/60376
https://bugs.archlinux.org/task/59503
Comment by Bjoern Franke (bjo) - Sunday, 09 December 2018, 11:35 GMT
Aye, sorry for the noise.

Loading...