Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#60957 - [man-pages-de] Significant changes in upstream package structure

Attached to Project: Community Packages
Opened by Mario Blättermann (mariobl) - Monday, 03 December 2018, 10:42 GMT
Last edited by Eli Schwartz (eschwartz) - Monday, 03 December 2018, 12:48 GMT
Task Type General Gripe
Category Packages
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Hi Jaroslav,

first, many thanks for maintaining this package. In most distributions it is either unavailable or terribly outdated, but yours is always up-to-date!

I'm one of the upstream authors (translators) of man-pages-de. Recently we have expanded our infrastructure to support »foreign« distributions directly. Previously, only Debian was supported, and all the upstream manpages came from Debian packages.

Now we have a new subdirectory »secondary-archlinux«. This means, the original man pages will be kept in sync with those from the Archlinux packages, and this way the translation templates are always up-to-date (after a semi-automatic sync task). Additionally, it enables the creation and synchronization of translations for man pages which are not available from Debian. During the last weeks I've translated the man pages included in »pacman« and »pacman-contrib«. For the latter, the po files are already complete, and the Pacman stuff is almost finished, still needs to be proofread. This means that the next upstream version of man-pages-de will ship them for the benefit of the German users.

What's the consequence for the Archlinux package? You have to add the switch --enable-distribution=archlinux to the ./configure line. This switches from the Debian default to Archlinux, as desired.

Makepkg also allows builds from VCS sources and checks them out directly. This way we would be independent from the upstream release policy and could target to Pacman releases instead (after the man page translations have been completed). But I wouldn't recommend this for the time being. First I will figure out what tweaks are needed for a VCS checkout to make it correctly working with the current state of the secondary distributions available.

Best Regards,
Mario
This task depends upon

Closed by  Eli Schwartz (eschwartz)
Monday, 03 December 2018, 12:48 GMT
Reason for closing:  Not a bug
Additional comments about closing:  We will package this as soon as it is released, and at that time the new manpages should be packaged. If for some reason the maintainer forgets or doesn't notice, then please request to reopen this bug.

As a matter of policy, we don't track issues for packaging changes to unreleased software -- we just assume the maintainer will read the changelogs and adapt as needed on their own.

Loading...