Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#60942 - [skia-sharp] libSkiaSharp.so: symbol lookup error: undefined symbol: WebPMuxSetChunk (fatal)

Attached to Project: Community Packages
Opened by John Lenz (wuzzeb) - Friday, 30 November 2018, 21:51 GMT
Last edited by Maxime Gauduin (Alucryd) - Friday, 17 May 2019, 15:06 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Maxime Gauduin (Alucryd)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

When using skia-sharp archlinux package 1.60.2 and then SkiaSharp package version 1.60.2 from nuget with dotnet core, I get an exception System.TypeInitializationException: The type initializer for 'SkiaSharp.SKImageInfo' threw an exception. ---> System.DllNotFoundException.

Running with LD_DEBUG=libs gives the following error:

/usr/lib/libSkiaSharp.so: error: symbol lookup error: undefined symbol: WebPMuxSetChunk (fatal)

I then uninstalled the skia-sharp archlinux package and instead tried the new https://www.nuget.org/packages/SkiaSharp.NativeAssets.Linux package. This package worked and I was able to use SkiaSharp 1.68.0-preview28 to create and draw some images (only light testing, but libSkiaSharp.so does load properly).
This task depends upon

Closed by  Maxime Gauduin (Alucryd)
Friday, 17 May 2019, 15:06 GMT
Reason for closing:  No response
Comment by Maxime Gauduin (Alucryd) - Friday, 12 April 2019, 16:52 GMT
Does it still happen with our 1.68 version?

Loading...