Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#60926 - [grub] grub.cfg.pacsave message is wrong

Attached to Project: Arch Linux
Opened by Peter Weber (hoschi) - Wednesday, 28 November 2018, 14:58 GMT
Last edited by Eli Schwartz (eschwartz) - Wednesday, 28 November 2018, 15:00 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To No-one
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
Hello!
As far as I understand, the latest grub doesn't provide an built-in 'grub.cfg' therefore the package should move the pacsave back into place and leave everything, as it was. Probably we message is just a side-effect and doesn't harm, but of course it scares me to read it and doesn't find a '.pacsave'.


Additional info:
* package version(s): grub 2:2.02-8
* config and/or log files etc.:
-backup=('boot/grub/grub.cfg'
- 'etc/default/grub'
+backup=('etc/default/grub'

+#!/bin/sh
+
+post_upgrade() {
+ # We used to package /boot/grub/grub.cfg, but there is no reason to.
+ # Remove the file from package, but move real file back in place.
+ if [ ! -f /boot/grub/grub.cfg -a -f /boot/grub/grub.cfg.pacsave ]; then
+ mv /boot/grub/grub.cfg.pacsave /boot/grub/grub.cfg
fi
+}


Steps to reproduce:
1.) # pacman -Syu
This task depends upon

Closed by  Eli Schwartz (eschwartz)
Wednesday, 28 November 2018, 15:00 GMT
Reason for closing:  Not a bug
Additional comments about closing:  The message comes from pacman itself when it notices the package no longer provides a "backup" file.

This is a one-time event.

Loading...