Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#60925 - [bash-language-server] incompatible with nodejs-lts-carbon/dubnium

Attached to Project: Community Packages
Opened by Julio (JulioJu) - Wednesday, 28 November 2018, 14:29 GMT
Last edited by Eli Schwartz (eschwartz) - Wednesday, 28 November 2018, 14:44 GMT
Task Type Bug Report
Category Packages
Status Assigned
Assigned To Felix Yan (felixonmars)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 1
Private No

Details

Description:

Hi !

This package seems to not be compatible with the package nodejs-lts-carbon and nodejs-lts-dubnium, but only with the package nodejs. See https://github.com/mads-hartmann/bash-language-server/issues/93.

Maybe, could you add this requierement on the PKGBUILD?

Thanks in advance
This task depends upon

Comment by Jelle van der Waa (jelly) - Wednesday, 28 November 2018, 14:40 GMT
It already depends on nodejs.
Comment by Eli Schwartz (eschwartz) - Wednesday, 28 November 2018, 14:44 GMT
  • Field changed: Summary ([bash-language-server] incompatibel with nodejs-lts-carbon/dubnium → [bash-language-server] incompatible with nodejs-lts-carbon/dubnium)
  • Field changed: Details
  • Field changed: Status (Unconfirmed → Assigned)
  • Task assigned to Felix Yan (felixonmars)
I guess we could add a versioned dependency on nodejs, *since we officially support multiple provides* for the lts releases to be drop-in replacements.
Comment by Felix Yan (felixonmars) - Thursday, 21 February 2019, 20:01 GMT
Looks like upstream works on making sure it works on nodejs 10. Does it work with nodejs-lts-dubnium currently?

Loading...